shared ip

Discussion in 'Server Operation' started by thedoc, Feb 26, 2008.

  1. thedoc

    thedoc New Member

    problem with shared ip page

    I have hunted through your forums and have not found a solution to this. I have ispconfig installed in VMware on an XP box. When I set up a site in the control panel and try to navigate to the page I get a shared ip page. Here are both outputs. I have also run httpd -t and it says syntax okay. This is driving me nuts. Your help is appreciated.

    Vhost
    NameVirtualHost 192.168.2.15:80
    <VirtualHost 192.168.2.15:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 192.168.2.5:80
    <VirtualHost 192.168.2.5:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 192.168.2.7:80
    <VirtualHost 192.168.2.7:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 192.168.2.8:80
    <VirtualHost 192.168.2.8:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    NameVirtualHost 192.168.2.9:80
    <VirtualHost 192.168.2.9:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.sanctity-mu.net:80
    ######################################
    #
    #
    <VirtualHost 192.168.2.7:80>
    ServerName www.sanctity-mu.net:80
    ServerAdmin webmaster@sanctity-mu.net
    DocumentRoot /var/www/web1/web
    ServerAlias sanctity-mu.net
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    Alias /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    <IfModule mod_ruby.c>
    <Directory /var/www/web1/web>
    Options +ExecCGI
    </Directory>
    RubyRequire apache/ruby-run
    #RubySafeLevel 0
    <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    </IfModule>
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #

    ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0C:29:09:33:80
    inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fe09:3380/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:9803 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6738 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2426011 (2.3 MiB) TX bytes:1392111 (1.3 MiB)
    Interrupt:169 Base address:0x2000

    eth0:2 Link encap:Ethernet HWaddr 00:0C:29:09:33:80
    inet addr:192.168.2.7 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:169 Base address:0x2000

    eth0:3 Link encap:Ethernet HWaddr 00:0C:29:09:33:80
    inet addr:192.168.2.8 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:169 Base address:0x2000

    eth0:4 Link encap:Ethernet HWaddr 00:0C:29:09:33:80
    inet addr:192.168.2.9 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:169 Base address:0x2000

    eth0:5 Link encap:Ethernet HWaddr 00:0C:29:09:33:80
    inet addr:192.168.2.15 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:169 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1620 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1620 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:147332 (143.8 KiB) TX bytes:147332 (143.8 KiB)
     
    Last edited: Feb 26, 2008
  2. Ben

    Ben HowtoForge Supporter

    What do you exactly mean by "navigate to the page"?`Do you just enter the IP adress? If so that won't work.
    You have to set an entry in your hosts file, so that you browser is able to look up the DNS-Name to the local IP....
    you may find your hosts file on your windows machine at %WINDIR%\SYSMTEM32\drivers\etc\hosts
     
  3. thedoc

    thedoc New Member

    problem with shared ip

    I know how to set my hosts file on my xp machine but the website i set up for the second ip, the one at 192.168.2.7, can not be seen from the web. When anyone tries to view the page they see shared ip page and not the default ISPconfig page. you can check this by going to http://sanctity-mu.net
    Also I would like to add that this site's DNS is handled at godaddy not on my own server.
    So to further explain my server is hosted on 192.168.2.5. I have an IRCD running on 192.168.2.15 I would like to use 192.168.2.7, 192.168.2.8 and 192.168.2.9 for web pages
    let me also add that I can connect to the site with ftp, and ssh via ip address or domain name
     
    Last edited: Feb 27, 2008
  4. falko

    falko Super Moderator

    Did you forward port 80 from your router to 192.168.2.7?

    BTW, you can forward port 80 to only one internal IP address, so you cannot host web sites on 192.168.2.7, 192.168.2.8, and 192.168.2.9 at the same time.
     
  5. thedoc

    thedoc New Member

    shared ip page

    I have the firewall turned off in my router and no firewall on my xp or my linux configuration.
     
  6. falko

    falko Super Moderator

    But did you forward port 80 from your router to 192.168.2.7?
     

Share This Page