Shared IP with Gateway server, ISPConfig and Proxy Pass?

Discussion in 'Installation/Configuration' started by domh, Jan 20, 2008.

  1. domh

    domh New Member

    Hi All,

    Thank you in advance for any assistance. I have the following problem:

    I am currently running two servers, one SME 7.3 as my gateway and one ISPCONFIG Server installed on Centos 5 using the perfect setup installation.

    My SME box is configured thus:

    router doing a DMZ on all ports to the SME box on first network card. to
    Second Network card for internal (configured as a gateway server)

    Proxy pass for individual domains to ISPCONFIG server ( This is what I was recommended it may not be correct.

    I have a virtual domain on the gateway server proxy_passed to the ISPCONFIG server but all I get is the shared IP error message.

    When I do a port forward TCP/UDP for port 80 it all works fine but I would like to forward all domain traffic (web, ftp, mail etc) to the ISPCONFIG server based on domain.

    I have found out that if I type in the server name it also comes up with the shared IP page. Seems that my proxypass is going to the sever name instead of the site I want it to pick up at the other end.

    Can someone please help me with this configuration?

    Thanks again

    Last edited: Jan 20, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The revommended configuration for ISPConfig is to forward port 80 to the server. the reson is that ISPConfig uses namebased virtual hosts, your proxy seems to contacts the IP address of the server and not the domain name, which results in the sahred IP address as apache is not able to determine the name of the reuested website.

Share This Page