Shared IP problem again!

Discussion in 'General' started by thanhdiepts, Oct 6, 2009.

  1. thanhdiepts

    thanhdiepts New Member

    Hi all,

    I setup CentOs with latest ISPConfig 2, but after I created some websites, Shared IP page appeared when I access these site. Here is my ifconfig and Vhosts_ispconfig result:

    wait for your help! thanks,
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Code:
    mh1:~# dig itdls1.no-ip.info
    
    ; <<>> DiG 9.3.4 <<>> itdls1.no-ip.info
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28539
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;itdls1.no-ip.info.             IN      A
    
    ;; ANSWER SECTION:
    itdls1.no-ip.info.      360     IN      A       [B][COLOR="Red"]69.65.19.125[/COLOR][/B]
    
    ;; Query time: 176 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Wed Oct  7 13:47:30 2009
    ;; MSG SIZE  rcvd: 51
    
    mh1:~#
    itdls1.no-ip.info is pointing to a wrong IP.
     
  3. thanhdiepts

    thanhdiepts New Member

    Thank falko, it works again!
     
  4. wanderer

    wanderer New Member

    I have a problem related to shared IP. I set up ispconfig 2 on Ubuntu 8 all services work fine from lan and from outside, with one exception. Called http server ip in the LAN message is "the shared". Called from outside the LAN http works perfectly. I appreciate any help given. Thanks
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you have selected the internal IP address and not external IP in the website settings.
     
  6. wanderer

    wanderer New Member

    I check now. It's 192.168.... ip set up in web settings.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You must use the correct domain or hostname to access a site - you cannot use the IP address because ISPConfig configures name-based vhosts.
     
  8. wanderer

    wanderer New Member

    Sorry for the error, I tried with the correct domain and give the same result.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf, and what is the output of
    Code:
    ifconfig
    ?
     
  10. wanderer

    wanderer New Member

    Thanks FALKO but I changed my mind about using ISPConfig and I want to set up services without it, I posted on another post problems faced to the mail service.
     

Share This Page