"Shared IP" error message: the SOLUTION

Discussion in 'Tips/Tricks/Mods' started by pierrepont, Jun 3, 2007.

  1. pierrepont

    pierrepont New Member

    Like MANY of you, I have also been PLAGUED by this pesky IP SHARED error, that I see in the boards a lot of people are having.

    I'm not a technical guy at all, so I don't know the "why" about any of this, but I HAVE THE SOLUTION for the SHARED IP BLUE SCREEN of DEATH:

    ISP Manager --> Sites --> YourDomain.com --> Co-Domains

    click on the IP address listed under Co-Domains, it takes you to --> ISP Domains

    Once in the "ISP Domains" section, GET RID OF THE 'www' in the "Hostname", which is the first field there. LEAVE THE HOSTNAME FIELD EMPTY, and click save.

    Go back to your domain, and you will see the IP SHARED problem is GONE.


    PS: why the heck in one screen is mandatory to enter 'www' in the Hostname department and it's deadly in another, I don't know. Why does it work with the hostname field empty, I don't know. I would make a note on the program itself as a "tip"of those little things... I can imaqine a lot of people were turned off by ISP Config due to IP SHARED and another pesky, baffling errors. Which is a shame because it's a GREAT piece of software, and it's open source, etc.
    Last edited: Jun 3, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The method mentioned above is not nescessary at all as this co-domain is created automatically by ISPConfig. The poster has set the domain limit too low so that ISPConfig was not allowed to add the nescessary co-domain Thats all.

    The www is not manadatory for co-domains, just for websites. The co-domain is added automatically if you dont set the limit too low. This has also been explained in many posts here in the forum.

Share This Page