"sh: /which ..." error during install

Discussion in 'Installation/Configuration' started by Joern, Apr 15, 2009.

  1. Joern

    Joern New Member

    Hey there!

    I am trying to install ISPConfig3.1.1. on my Ubuntu system.
    I am following the directions given in the HowToForge tutorial "The perfect server - Ubuntu 8.10".
    The system was already set up so I skipped a few steps in the tutorial - because e.g. MySQL was already installed.

    Anyway, when I try to install ISPConfig with the command
    Code:
    php -q install.php
    I get this error message sixteen times
    Code:
    sh: /which: No such file or directory
    sh: /which: No such file or directory
    sh: /which: No such file or directory
    ...
    Anyhow I try to proceed...
    I answer the questions starting which language I would like to use and which installation mode I would like.
    After the installation mode question I get the following error
    Code:
    sh: /hostname: No such file or directory
    
    Notice: Undefined offset:  0 in /tmp/ispconfig3_install/install/install.php on line 105
    
    I keep on entering the information about the FQDN and the database information. After the last question about the charset I get the following error message
    Code:
    sh: /mysql: No such file or directory
    sh: /echo: No such file or directory
    ERROR: Unable to load SQL-Dump into database table.
    Then the install script stops.
    I can see that the script was able though to create the database named "dbispconfig". Anyhow it is empty...

    So this is my problem during the install.
    Is there anyone who could try to help me solve this problem?
    It would be great!

    Thanks a lot in advance,

    Joern
     
  2. till

    till Super Moderator

    Please login as root user before you execute the setup script. You can not execute it with sudo!
     
  3. Joern

    Joern New Member

    Thanks for your reply, Till.
    I disabled root login.
    Therefor I login with my username and then grant root access by doing this
    Code:
    su -
    That's what I was doing before already.

    Or do you think I really need to login as root and not do it the way I mentioned above?
     
    Last edited: Apr 15, 2009
  4. Joern

    Joern New Member

    I just tried it again by login in directly as user 'root' - but same result as if I do it as I mentioned above... Same error msgs as well! :(
     
  5. till

    till Super Moderator

    Please post the output of:

    echo $PATH
     

Share This Page