several problems

Discussion in 'General' started by PermaNoob, Oct 4, 2010.

  1. PermaNoob

    PermaNoob New Member

    1. Somehow one of my client sites became the default domain for my server ip--enter the ip alone and his site comes up. I have no idea how that happened--nothing was done but to add the site in ISPConfig 3.

    How do I change it back?

    2. Got the

    "Forbidden

    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

    error for several sites and found that the permissions were wrong on the web directories for those sites.

    What could cause that? They were setup in ISPConfig 3 and I never changed any permissions.

    3. One site won't come up at all but goes to the wrong default site I mention above--the vhost file shows the correct directory and I've checked and rechecked the files and permissions--nothing seems to work.

    4. All sites setup under one client had a strange sftp connection problem when I was copying over the tar file of the site. The username was accepted, but when the password was entered, the connection was closed.

    Triple-checked the passwords were correct, deleted the sites and reinstalled them in ISPconfig 3, still same error--had to give up and delete the Client and start over.

    Most of the sites work fine and without problems, so it's weird that it's just some of the sites that have these errors.

    Using Debian Lenny.
     
    Last edited: Oct 4, 2010
  2. ivomendonca

    ivomendonca Banned

    1 - is normal not a bug.
    2 - dont use the * for ip.
    3- maybe somewone changed to suexec and the permissions are all wrong.
     
  3. till

    till Super Moderator

  4. PermaNoob

    PermaNoob New Member

    the websites exist

    I created a test subdirectory and subdomain in ispconfig pointing to that directory and that works, but the main domain still just redirects to the ip as though there is no apache record.

    I DID select the ip address and not *.
     
  5. PermaNoob

    PermaNoob New Member

    Seems it was a problem with the Firefox cache--even though I hit reload. Tried Safari and it directed to the correct directory, though now the images won't load, and Firefox still goes to the default website instead of the correct directory, though I restarted it and cleared the cache and cookies.

    As for problem 4, had that happen again today and I had to turn off Jailkit to be able to connect by sftp with the user's login.
     
    Last edited: Oct 4, 2010
  6. PermaNoob

    PermaNoob New Member

    I've discovered that the domains don't work with www in front of the domain name--anyone know how to make www.domain.com work?

    I use the domain registrar's dns, and www is in the address pointing to the domain along with the domain without www.

    nvm, found the solution:

    Log in to ISPconfig , then click on sites , then select the site and then select "Auto-subdomain" to www. and press save
     
    Last edited: Oct 4, 2010
  7. edge

    edge HowtoForge Supporter

    As for point 1

    If you 1st had domain's b.com, c.com and d.com the site b.com will showup when you enter the IP of the server.
    If you later add domain a.com, than this wil become the one that will showup when the IP is used.
    Apache is reading the vhost files in alphabetical order.

    An easy fix if you want b.com tobe the site to showup when an IP is entered is to create a symlink in /etc/apache2/sites-enabled named @000-b.com and point it to /etc/apache2/sites-enabled/b.com.vhost

    Make sure that you restart apache again when done.
     
  8. PermaNoob

    PermaNoob New Member

    ok, thanks for that help.

    I think I figured out the problem with the web directory ownership as root and permissions problem--I had changed the shell user login to the web directory like /var/www/clients/client3/web9/web instead of /var/www/clients/client3/web9 thinking that would make it more convenient for them so that when they logged in to upload files they wouldn't have to change to the web directory (yeah, they usually just start uploading wherever they login, even if the instructions to upload to the web directory are right in front of them), but apparently that screws things up if you're using jailkit.
     
  9. PermaNoob

    PermaNoob New Member

    Now I've got 2 domains which won't resolve to the correct directory.

    nvm, time fixed it.
     
    Last edited: Oct 5, 2010

Share This Page