several issues

Discussion in 'Installation/Configuration' started by nickpieters, May 19, 2009.

  1. nickpieters

    nickpieters New Member

    Hi

    I have several issues, and don't understand why this is happening, server is running sinces 2 months now. Installation was with the vmware image and manual downloaded here.

    1. Can't update, when i try to run the php script: php -q update.php i get this:
    Fatal error: Cannot use string offset as an array in /home/administrator/ispconfig3_install/install/update.php on line 146

    2. Now whenever i want to add a database, site whatever nothing happends. It gets on the webfront of the ispconfig site. But no /var/client etc... folder is made, also checked on phpmyadmin also there no added database.

    3. Serverconfig etc. is empty on the ispconfig site

    Anyobody that could help me?

    thx!
     
  2. ago2guy

    ago2guy New Member

    It looks like most changes get added to the "Jobs Queue" Which runs about every 5 minutes.

    You can check if your job has run by clicking Monitor > show Jobqueue
     
  3. nickpieters

    nickpieters New Member

    Thx for your input.

    Waited, but no database or folders are beïng made.

    Any other idea's?
     
  4. nickpieters

    nickpieters New Member

    Okay, folders are made in /var/clients/client1.

    Made an ftp user, connecting is okay, but whenever i want to upload i get a permission denied now...

    in /tmp i can write, /web not :-(
     
    Last edited: May 19, 2009
  5. ago2guy

    ago2guy New Member

    Can you check the permissions on the client1 folder. I did the same myself last week and did not have this issue.

    Make sure the Client Limits are set in the Clients section and also check the FTP user limits and disk quota.

    The FTP usernames can get quite long as well. make sure you spelt it correctly as displayed in the FTP users list. I made that mistake myself.
     
  6. nickpieters

    nickpieters New Member

    ls -l, gives me

    drwxr-xr-x 3 root root 4096 2009-03-04 10:25 clients
    drwxr-xr-x 6 root root 4096 2009-05-18 14:38 client1

    more info:

    lrwxrwxrwx 1 root root 26 2009-03-12 11:46 domain.be -> /var/clients/client1/web5/
    lrwxrwxrwx 1 root root 26 2009-03-11 16:39 domain.be -> /var/clients/client1/web3/
    lrwxrwxrwx 1 root root 26 2009-03-11 16:05 domain.be -> /var/clients/client1/web2/
    drwxr-xr-x 6 root root 4096 2009-05-18 15:23 domain
    drwxr-xr-x 6 root root 4096 2009-05-18 15:25 web12
    drwxr-xr-x 6 root root 4096 2009-03-11 16:05 web2
    drwxr-xr-x 6 root root 4096 2009-03-11 16:39 web3
    drwxr-xr-x 6 root root 4096 2009-03-12 11:46 web5


    Notice the links.
     
    Last edited: May 19, 2009
  7. ago2guy

    ago2guy New Member

    Sorry, I should have been more clear.

    I meant the specific folder for client 1 (i.e the clients web folder )

    I my case Client1 > web2 folder should look somthing like this

    root@glue:/var/www/clients/client1/web2# ls -al
    total 24
    drwxr-xr-x 6 root root 4096 2009-05-14 19:47 .
    drwxr-xr-x 4 root root 4096 2009-05-14 19:47 ..
    drwxr-xr-x 2 web2 client1 4096 2009-05-14 19:47 cgi-bin
    lrwxrwxrwx 1 web2 client1 35 2009-05-14 19:47 log -> /var/log/ispconfig/httpd/domain.tld
    drwxr-xr-x 2 web2 client1 4096 2009-05-19 13:49 ssl
    drwxrwxrwx 2 web2 client1 4096 2009-05-14 19:47 tmp
    drwxr-xr-x 5 web2 client1 4096 2009-05-14 20:05 web


    The owner is web2 and its in the group client1 in my case it may not be the same for you
     
  8. nickpieters

    nickpieters New Member

    mars:/var/clients/client1# ls -al web12
    total 24
    drwxr-xr-x 6 root root 4096 2009-05-18 15:25 .
    drwxr-xr-x 7 root root 4096 2009-05-18 15:25 ..
    drwxr-xr-x 2 root root 4096 2009-05-18 15:25 cgi-bin
    lrwxrwxrwx 1 root root 37 2009-05-18 15:25 log -> /var/log/ispconfig/httpd/domain.be
    drwxr-xr-x 2 root root 4096 2009-05-18 15:25 ssl
    drwxrwxrwx 2 root root 4096 2009-05-18 15:25 tmp
    drwxr-xr-x 3 root root 4096 2009-05-18 15:25 web

    It's just like iscponfig isn't doing all the things it should be.

    for example. Do you enter the Documentroot in sites and in FTP users, do you enter the directory?
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You tried to update which version which which version?
     
  10. nickpieters

    nickpieters New Member

    3.0.0.9 (was the version when i followed the htf guide).

    The script doesn't work, and php -q gave me the error.

    I have the feeling that this i rather a beta release, am i wrong with this?
     
    Last edited: May 19, 2009
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, this is a beta relaese that was relaesed before the final (3.0.1) for testing purposes. It might be that there are updating probplems with this release. Please try to update your server to the latest stable release (3.0.1.1).
     
  12. nickpieters

    nickpieters New Member

    That is the problem, i can't upgrade.

    In my first post i posted the error. If i could upgrade it, i think all the rest would work again..
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The error message means that your server configuration is either empty or incomplete in the database. Thats also the reason why nothing gets created as there is all the information about your system missing.

    You should run the uninstall.php script to remove ispconfig from the system and then install the ispconfig 3.0.1.1 release.
     

Share This Page