Setup website under ISP and deploy Redmine

Discussion in 'Installation/Configuration' started by Poliman, Dec 5, 2018.

  1. Poliman

    Poliman Member

    I need to backup Redmine from old server and move it to server based on Perfect Server setup with Ubuntu 16.04 LTS and newest ISP install. I saw that Redmine uses own webserver like Webrick, Puma or few others but probably not Apache (I see only default vhost in sites-enabled). I would like to create Website using ISP and under it deploy Redmine. Is it possible? How? Docs says about Webrick server but only for development.

    PS
    How determine which server is used by Redmine? I can't trace neither port nor name of the server used.
     
    Last edited: Dec 5, 2018
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Some years ago I remember converting a webrick setup to apache+passenger, though I don't remember many details. I followed a guide and it was pretty straightforward/just worked. Search for guides/info, but you could start with https://www.phusionpassenger.com/library/install/apache/install/oss/xenial/ to get the software installed. As for the vhost configuration, check documentation or search for examples, I don't have anything handy; maybe someone else will reply who does though. Ask furher questions and we could probably help work out anything specific to the ISPConfig environment if there is any.
     
  3. Poliman

    Poliman Member

    Thank you for answer. I have found this link and currently deployed it on my testing environment. Now I am going to install Redmine. I will ask here if any questions appear.
     
  4. Poliman

    Poliman Member

    Ok, so problems have started appearing. This Redmine old project need to be moved on new server. There is - by default - Ruby 2.3.1. I need to use Ruby 1.9.3, so I installed it by:
    Code:
    sudo apt-add-repository -y ppa:rael-gc/rvm
    sudo apt-get update
    sudo apt-get install rvm
    rvm install "ruby-1.9.3-p551"
    gem install rails -v=3.2.13
    
    Then I set default ruby to needed version:
    Code:
    rvm --default use 1.9.3
    Moreover I use this tutorial. In 4th point "Dependencies installation" I need to execute two commands:
    Code:
    gem install bundler
    bundle install --without development test
    First one works but second one produce:
    Code:
    Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break
    this application for all non-root users on this machine.
    The dependency jruby-openssl (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for java. To add those platforms to the bundle, run `bundle lock --add-platform java`.
    The dependency activerecord-jdbcmysql-adapter (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for java. To add those platforms to the bundle, run `bundle lock --add-platform java`.
    The dependency activerecord-jdbcpostgresql-adapter (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for java. To add those platforms to the bundle, run `bundle lock --add-platform java`.
    The dependency activerecord-jdbcsqlite3-adapter (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for java. To add those platforms to the bundle, run `bundle lock --add-platform java`.
    Fetching gem metadata from http://rubygems.org/..........
    Fetching gem metadata from http://rubygems.org/.
    Resolving dependencies...
    Using rake 12.3.1
    [...]
    Using rack-ssl 1.3.4
    Fetching json 1.8.6
    Installing json 1.8.6 with native extensions
    Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
    
        current directory: /var/lib/gems/2.3.0/gems/json-1.8.6/ext/json/ext/generator
    /usr/bin/ruby2.3 -r ./siteconf20181206-88776-1pzt6fu.rb extconf.rb
    mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h
    
    extconf failed, exit code 1
    
    Gem files will remain installed in /var/lib/gems/2.3.0/gems/json-1.8.6 for inspection.
    Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/json-1.8.6/gem_make.out
    
    An error occurred while installing json (1.8.6), and Bundler cannot continue.
    Make sure that `gem install json -v '1.8.6' --source 'http://rubygems.org/'` succeeds before bundling.
    
    In Gemfile:
      jquery-rails was resolved to 2.0.3, which depends on
        railties was resolved to 3.2.13, which depends on
          rdoc was resolved to 3.12.2, which depends on
            json
    
    I tried
    Code:
    gem install json -v '1.8.6'
    but it produces:
    Code:
    [email protected]:/var/www/clients/client2/web2/web# gem install json -v '1.8.6'
    Building native extensions.  This could take a while...
    ERROR:  Error installing json:
            ERROR: Failed to build gem native extension.
    
        current directory: /var/lib/gems/2.3.0/gems/json-1.8.6/ext/json/ext/generator
    /usr/bin/ruby2.3 -r ./siteconf20181206-89002-13fpad6.rb extconf.rb
    mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h
    
    extconf failed, exit code 1
    
    Gem files will remain installed in /var/lib/gems/2.3.0/gems/json-1.8.6 for inspection.
    Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/json-1.8.6/gem_make.out
    
    Strange thing, because in above errors is line /var/lib/gems/2.3.0/gems/json-1.8.6, which could suggests that I don't use ruby 1.9.3 but still default provided by Ubuntu 16.04. I googled a lot and tried different things, install some libs. Nothing moves this case ahead.
     

Share This Page