setup questions from a new user

Discussion in 'Installation/Configuration' started by PaulDG, Dec 13, 2011.

  1. PaulDG

    PaulDG New Member


    I have just installed Ispconfig 3 using this guide: The Perfect Server – Ubuntu 11.10 [ISPConfig 3]

    My first question is about the client, I am the sole admin for this server and will not be delegating any responsibilities to others.
    Is it better to create a client for myself? or run without a client defined?

    The default website in var/www created when apache was installed shows up when the server is called via its IP address, I have created a site in Ispconfig and it works ok when called with its domain.
    I thought I read that the first (alphabetically) vhost was supposed to show when the IP was used.
    I also read that I should use the IP address instead of the * when creating sites, but only the * is available in the drop down box.

    Under System > Server Config > myserver > server
    The IP address and Netmask are ok but the Gateway and Nameserver fields are incorrect.
    My IP is but the Gateway is set to and the Namservers are and
    Should I correct them?

    Thanks to all involved with this prolect and thanks for any help.

  2. falko

    falko Super Moderator ISPConfig Developer

    In your case it's not needed, but I think I'd do it anyway.

    The first defined vhost shows up, and that's the "It works!" page.

    It your vhost work, the * is ok.
    You can define your IP addresses under System > IP addresses (or something like that); afterwards the IPs are available in the IP drop-down menu.

    That's not necessary unless you let ISPConfig manage your network configuration (which is not recommended). If you don't have ISPConfig manage your network configuration, these fields have no function.
  3. PaulDG

    PaulDG New Member

    Thanks for the info.

    If I understand this correctly, -
    The first defined vhost is the one created before ispconfig is installed and that is the "It Works!" page

    The first site created in ispconfig would become the 2nd vhost and have the "Welcome to your website!" heading.

    Ok if my above assumptions are correct then how do I update the content in the "it Works"" page as ftp access for the account created during server setup is restricted to the home directory

    and the same question about the options for that page like cgi php?

    Again thanks for your help

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You dont use this directory and FTP user on a server where ispconfig is installed. Instead follow these steps:

    1) Ensure that you selected the correct IP address in the website settings, if the IP address is not listed there, add it under System > Server IP
    2) Create a FTP user in ispconfig and upload the web contents with this FTP user into the web directory of the website.
  5. PaulDG

    PaulDG New Member

    I can't do that, the site I am talking about is the "It works!" site, it wasnt created in ispconfig so it doesnt show up in the drop down list of sites presented when you create an ftp user.

    Maybe I missed a step that disables this initial site or I am not understanding things correctly.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so your problem is that you missed to create a website for your domain in ispconfig even if you described above that you did this already.

    The it works page is no site. It is the placeholder that is shown if you have not created a site yet and there is no need to disable anything. Just create your website and the it works page will not be displayed anymore if you enter the domain name of this website in the webbrowser.

    1) Login to ISPConfig.
    2) Create your new website for your domain, ensure that you select the IP address as I described above and not *.
    3) Create a FTP user and upload the content to the web folder of this website.

    then access the website by its domain name, sites cant be accessed by IP address. If you did not register the domain yet, see here:

    The detailed steps are also described in the ISPConfig manual.
    Last edited: Dec 15, 2011
  7. PaulDG

    PaulDG New Member

    No, Thats not my problem :(
    I have already done that and when I access it with the domain name it works as its supposed to.

    I am asking about the "It Works" placeholder, it shows up if the IP is used instead of a domain name. I want to stop it showing up OR change it for something more relavent.

  8. falko

    falko Super Moderator ISPConfig Developer

    You can replace the "It works" page in the /var/www directory.
  9. PaulDG

    PaulDG New Member


  10. falko

    falko Super Moderator ISPConfig Developer

    You can use a tool like WinSCP and connect as root.
  11. PaulDG

    PaulDG New Member

    Ok Falko, I got that to work.

    Many thanks


Share This Page