Setup non-latin names in ISPConfig DNS

Discussion in 'General' started by ahmadt, Feb 15, 2011.

  1. ahmadt

    ahmadt New Member

    Dears,

    I just registered an Arabic Domain name and I got the latin DNS name for it (xn----ymcaabclf0d4kdgv8cj.xn--mgberp4a5d4ar) and everytime I try to add it to ISPconfig DNS tab it will give me the following error:

    "Zone has a invalid format."

    I could add it directly to BIND but I'm sure ISPConfig will overwrite it soon or later.

    Do you have any solution for me?


    Thanks
     

    Attached Files:

    • dns.PNG
      dns.PNG
      File size:
      11.1 KB
      Views:
      99
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use?
     
  3. ahmadt

    ahmadt New Member

    Hi

    I'm using version 3.0.2
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Updating your ISPConfig install to the current version (3.0.3.2) should fix the issue.
     
  5. ahmadt

    ahmadt New Member

    Thanks

    any possible way to do the upgrade using the web interface? :)
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Updates should always be installed on the shell by running the command:

    ispconfig_update.sh

    as root user.
     
  7. dimas

    dimas Member

    I have to say that while the current version supports these names in most cases - but not all. At least once - in the slave DNS lib file - there's still the old regex. I had to change the file manually to make it work.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add a report to the bugtracker, so we can fix it in the next release.
     
  9. dimas

    dimas Member

    OK thank you I'll do that tomorrow.
     

Share This Page