Setup mailaccount

Discussion in 'HOWTO-Related Questions' started by mike, Apr 19, 2005.

  1. Happy

    Happy New Member

    duplicates

    There are no duplicates in the virtusertable. However, I entered them in webmin first so I am not sure why I got the warning
     
  2. falko

    falko Super Moderator

    I think the problem is that you use Webmin AND configure email addresses manually. Webmin has a different way to set up email addresses in Postfix than the method described here.
     
  3. Happy

    Happy New Member

    duplicates

    So do I need to remove all users from the virtualuserstable or leave it as is?
     
  4. falko

    falko Super Moderator

    I don't know what Webmin has done, so I think it's best to reinstall the system and then opt for just one way of managing your system (either by hand or with a control panel like Webmin).
     
  5. Happy

    Happy New Member

    webmin

    I just removed all users from virtualuserstable via webmin (no more duplicate warnings)and all is good, the mail server is up and running like a champ now. I want to thankyou for all your help. Another question ? I want to diasble root from telnet and also from acessing via webmin (https). I know I can turn root account to //bin/false to prevent this account from logging in via SSH on port 22. Now I need to figure out how to disable it in webmin (so it can not ;log in via the web interface). To me this is an open door as I have created another account that I use to administer the mail server with-any help would be great


    Thanks

    Happy
     
  6. v2k

    v2k New Member

    Is it necessary to create the user:

    Code:
    useradd -d /home/sample_user -g users sample_user
    passwd sample_user
    I skipped that step, and tried to use an already existing user?

    No matter who I send mail to, mail returns no mail.

    thanks,
    Vince.
     
  7. Happy

    Happy New Member

    email woes

    I would just use webmin to admin users add/remove/reset passwords check their mailbox etc

    If you like to install and update Webmin via APT, edit the /etc/apt/sources.list file on your system and add the line : deb http://download.webmin.com/download/repository sarge contrib You will now be able to install with the commands : apt-get update
    apt-get install webmin All dependencies should be resolved automatically.

    :eek:
     
  8. v2k

    v2k New Member

    Sounds scary. I've been doing everything manually so far, so I might as well keep it that way.
     
  9. falko

    falko Super Moderator

    No, you don'T have to do that if the user's already existing.
    Any errors in your mail log?
     
  10. v2k

    v2k New Member

    right, I had a domain error in postconf, but that didn't fix it:

    I ran some DNS tests on the mail server, and it seems to pass all the standard mail tests.

    (i replaced my actual domain with MYDOMAIN)

    Sep 14 11:30:41 MYDOMAIN sendmail[27225]: l8EIUfT1027225: from=root, size=41, class=0, nrcpts=1, msgid=<200709141830.l8EIUfT1027225@MYDOMAIN.com>, relay=root@localhost
    Sep 14 11:30:41 MYDOMAIN postfix/smtpd[27226]: connect from localhost.localdomain[127.0.0.1]
    Sep 14 11:30:41 MYDOMAIN postfix/smtpd[27226]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Sep 14 11:30:41 MYDOMAIN postfix/smtpd[27226]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Sep 14 11:30:41 MYDOMAIN sendmail[27225]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Sep 14 11:30:41 MYDOMAIN postfix/smtpd[27226]: 7E3EA31B02E3: client=localhost.localdomain[127.0.0.1], sasl_sender=root@MYDOMAIN.com
    Sep 14 11:30:41 MYDOMAIN postfix/cleanup[27229]: 7E3EA31B02E3: message-id=<200709141830.l8EIUfT1027225@MYDOMAIN.com>
    Sep 14 11:30:41 MYDOMAIN postfix/qmgr[28376]: 7E3EA31B02E3: from=<root@MYDOMAIN.com>, size=609, nrcpt=1 (queue active)
    Sep 14 11:30:41 MYDOMAIN sendmail[27225]: l8EIUfT1027225: to=v2k@MYDOMAIN.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30041, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 7E3EA31B02E3)
    Sep 14 11:30:41 MYDOMAIN postfix/local[27230]: 7E3EA31B02E3: to=<v2k@MYDOMAIN.com>, relay=local, delay=0.43, delays=0.2/0.01/0/0.23, dsn=2.0.0, status=sent (delivered to maildir)
    Sep 14 11:30:41 MYDOMAIN postfix/qmgr[28376]: 7E3EA31B02E3: removed
    Sep 14 11:30:42 MYDOMAIN postfix/smtpd[27226]: disconnect from localhost.localdomain[127.0.0.1]

    Note, there are files in Maildir/new, but "mail" says I have no mail.
     
  11. v2k

    v2k New Member

    Upon inspection, these files do contain my actual mail. So it's just that mail thinks I have none....

    pop3 works, so I guess it's not a big deal.
     
    Last edited: Sep 14, 2007
  12. falko

    falko Super Moderator

    What POP3 server do you use? What's the output of
    Code:
    netstat -tap
    ? You must use a POP3 daemon that uses Maildir.
     
  13. jimmypt

    jimmypt New Member

    Hi,

    i'm new here. I found this forum cause i got some troubles configuring a fedora with postfix. i follow all the steps and i don't understaind where's the problem is.

    could anyone help me please?

    now i can send, via telnet an email from my server. but i can't receive.

    help plz

    thx

    Jimmy
     
  14. falko

    falko Super Moderator

    Any errors in your mail log?

    Please make sure that the MX record of your domain points to the correct server. You can check that by running
    Code:
    dig mx yourdomain.com
     
  15. Mini

    Mini New Member

    Thanks a lot. That also worked for me.:)
     

Share This Page