./setup doesnt check if mysql libs exists

Discussion in 'Developers' Forum' started by Norman, Apr 20, 2009.

  1. Norman

    Norman Member HowtoForge Supporter

    ./setup exits with success status even though mysql couldn't be compiled properly after one debian of mine didnt have libmysqlclient15-dev packages.

    Maybe a check to see if mysql is compilable?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are you sure there were absolutely no error messages?
     
  3. Norman

    Norman Member HowtoForge Supporter

    No errors previous to compiling mysql headers.
    It then completed by cleaning out the /tmp/install_ispconfig but setup script still continued and tried to unpack spamassassin, apr.tar.gz and many other packages after mysql.

    Setup exited with a ispconfig installation complete message and proceeded to launch ispconfig. But it failed to start normal apache since cronolog wasn't compiled and had been removed out of /root/ispconfig . A lot of other directories under that directory were also empty.

    The backup files created by setup were also removed from /tmp since setup script had succeded (at least it thought so), luckily I always proceed to store another backup before upgrades so I could restore my SSL conf.

    Then I installed the mysql library package through apt-get, ran the setup again. Finished without errors, only thing I had to do was restore my SSL conf since that's the only thing I run custom.

    But Im guessing I would've had a lot of issues if the setup hadn't upgraded mysql tables properly if there had been changes from previous versions.
    Is there a way I can check to see if mysql table layout is correct?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Install the mysql database dump which is in the ispconfig installer into a new empty mysql database and compare the tables.
     
  5. Norman

    Norman Member HowtoForge Supporter

    The installer removed the install directory after it had exited with a success status (even though it wasnt actually successful).

    An installation of the libs and re-run of another extracted install archive worked though. It never touched the DB's so it works as supposed.

    I still think there's some issue there when it finds mysql-server but cant verify if there are some other libraries missing.
     

Share This Page