Settings to run TYPO3 on ISPConfig 3 ?

Discussion in 'Tips/Tricks/Mods' started by mzerbe, Sep 4, 2009.

  1. mzerbe

    mzerbe New Member

    Hi out there,

    has somebody managed to get TYPO3 running on ISPconfig 3? How to do?

    I am trying since two days now with no success. (If it is not possible, I'd have to reinstall the server with ISPconfig 2 where Typo works with just some apache directives.)

    Target is to have typo3_src (the core) in a directory like /opt/typo3/ or /usr/local/src or /var/www and not in the webX or clientX folder, since there will be a couple of websites connecting to that core.

    I am open for any suggestions.

    Regards from Bangkok.

    Mario
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3 has stricter security settings then ISPConfig 2, by default all files of a site have to be inside the website directory. But you can just change the vhost template (/usr/local/ispconfig/server/conf/vhost.conf.master) like you want it to be for such a global setup e.g. by removing the directory limits for mod_php. Please be aware that you should not use such global setups for servers that host several clients for security reasons.
     
  3. mzerbe

    mzerbe New Member

    SOLVED: Setting for a centralized Typo3 core

    Thanks Till,

    that was the hint I needed.

    Rather then deleting something, I added something to /usr/local/ispconfig/server/conf/vhost.conf.master

    Original File:
    Code:
    <tmpl_if name='php' op='==' value='mod'>
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i [email protected]<tmpl_var name='domain'>"       
        php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
        php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
    <tmpl_if name='security_level' op='==' value='20'>
        php_admin_value open_basedir <tmpl_var name='document_root'>/web:<tmpl_var name='document_root'>/tmp:/usr/share/php5
    Changes made: (scroll to right site in GREEN)
    Code:
    <tmpl_if name='php' op='==' value='mod'>
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i [email protected]<tmpl_var name='domain'>"       
        php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
        php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
    <tmpl_if name='security_level' op='==' value='20'>
        php_admin_value open_basedir <tmpl_var name='document_root'>/web:<tmpl_var name='document_root'>/tmp:/usr/share/php5[COLOR="DarkGreen"][B]:/opt/typo3[/B][/COLOR]
    That did the trick.

    I guess, I will have to restore that change after each run of ispconfig_update.sh
    Is there any possibility to have such settings in the server setup of a future version?
    e.g. something like /opt/applications (where additional central components can be stored?)

    Cheers
    Mario
     
  4. Hans

    Hans Moderator ISPConfig Developer

    TYPO3 as an Enterprise CMS on an ISPConfig3 server

    @mzerbe,

    Within the attachement of this post, i explain how you can install TYPO3 as an Enterprise CMS (central TYPO3 source) on an ISPConfig3 server.
    It's explained also how to upgrade to a newer version of TYPO3.

    It's my personal setup to run TYPO3 as an Enterprise CMS, other ways are possible as well, but i choose this way.

    I use this setup for many TYPO3 sites without any problem, so it might be helpful for you and/or others as well.
     

    Attached Files:

    Last edited: May 16, 2010
  5. medienlounge

    medienlounge New Member

    Hi Hans,
    perhaps you can help me.
    I got i Problem getting an old version of Typo3 running.

    Thought i did all of your textile above.

    mod_fcgid: stderr: PHP Fatal error: Uncaught exception 't3lib_error_Exception' with message 'PHP Runtime Notice: Non-static method t3lib_div::getClassName() should not be called statically in /var/www/clients/client1/web1/web/t3lib/class.t3lib_div.php line 5224' in /var/www/clients/client1/web1/web/t3lib/error/class.t3lib_error_errorhandler.php:101, referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: Stack trace:, referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: #0 /var/www/clients/client1/web1/web/t3lib/class.t3lib_div.php(5224): t3lib_error_ErrorHandler->handleError(2048, 'Non-static meth...', '/var/www/client...', 5224, Array), referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: #1 /var/www/clients/client1/web1/web/t3lib/class.t3lib_div.php(5224): t3lib_div::getClassName(), referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: #2 /var/www/clients/client1/web1/web/typo3/init.php(213): t3lib_div::makeInstance('t3lib_error_Pro...'), referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: #3 /var/www/clients/client1/web1/web/typo3/index.php(63): require('/var/www/client...'), referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: #4 {main}, referer: http://xyz.de/typo3/

    [Fri Dec 22 10:34:21 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: thrown in /var/www/clients/client1/web1/web/t3lib/error/class.t3lib_error_errorhandler.php on line 101, referer: http://xyz.de/typo3/

    [Fri Dec 22 10:44:29 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: PHP Fatal error: Class 'tx_dbal_querycache' not found in /var/www/clients/client1/web1/web/typo3_src-4.7.20/typo3/sysext/dbal/class.ux_t3lib_db.php on line 1327

    [Fri Dec 22 10:44:32 2017] [warn] [client 178.27.12.39] mod_fcgid: stderr: PHP Fatal error: Class 'tx_dbal_querycache' not found in /var/www/clients/client1/web1/web/typo3_src-4.7.20/typo3/sysext/dbal/class.ux_t3lib_db.php on line 1327
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the PHP version is too new. Install an additional older PHP version on the server, add it in ISPConfig under System > PHP versions and then select that older version in the website settings.
     
  7. medienlounge

    medienlounge New Member

    Hi Till,
    thanks for your fast reply.
    donĀ“t know if that fits in that topic now.
    I already tried to compile php 5.2(now running 5.5 on Debian 7 and mysql 5.5 the typo3 is old 4.7) but that doesn't work with the mysql version. so i hoped it could be an ispconfig config.
    any further help or a link to a working tutorial (some old don't work anymore as php and sql versions "increased).
    thanks a lot
     

Share This Page