Settings are getting updated anymore.

Discussion in 'General' started by SuperLOL, Feb 15, 2021.

  1. SuperLOL

    SuperLOL Member

    Hi,
    Since 3 weeks ago i noticed that the ISP Config settings are not getting updated anymore on my Debian 9 (Stretch).
    If i change any ISP Config setting then it gets put into the query at the Top Right corner, and it will never go away and the setting is also not being applied.
    I think this problem happened after a server update because i didn't change anything else for 2 months after upgrading from ISP Config 3.1.15p3 to ISP Config 3.2.2 and everything worked fine after the upgrade. :eek:

     
    Last edited: Feb 15, 2021
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    If you use other than default php for your OS on your server, that is normal result - a non working ISPConfig.
     
  3. SuperLOL

    SuperLOL Member

    I haven't changed anything on my server. ISP Config is still running on PHP7.0 like it always has.
    I also have all the PHP versions installed on my server (5.6, 7.0, 7.1, 7.2, 7.3, 7.4, 8.0)
     
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Run php -v, see the result, compare it with you OS default php version. I don't think 7.0 is default php version shipped with Debian Stretch but I could be wrong.
     
    SuperLOL likes this.
  5. SuperLOL

    SuperLOL Member

    You right the PHP version was set to 8.0.2. But i never changed that to v8.0.2. This must be this big PHP January update that has changed this to v8.0.2. :rolleyes:
    Here is the commands i used to chnage it back to v7.4. ;)
    Code:
    update-alternatives --config php
    update-alternatives --config php-cgi
     
    Last edited: Feb 15, 2021
  6. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    So far that I know Debian Stretch default php version is 7.0 while Debian Buster default php version is 7.3 but I could be wrong, again.
     
    Last edited: Feb 15, 2021
    SuperLOL likes this.
  7. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    I had this behavior too on one of my instalation debian 10, update of php, with new php 8.0 from sury repository change default php to 8. fixed using
    update-alternatives, two other debian 10 instalation dont suffer this behavior.
     
    SuperLOL likes this.
  8. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

  9. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Taleman and till like this.

Share This Page