setting www in DNS Manager

Discussion in 'General' started by Spaetzle, Nov 26, 2008.

  1. Spaetzle

    Spaetzle Member HowtoForge Supporter


    I have a little problem wit setting up some entries with DNS manager.
    Maybe somebody has an idea what is going worng here.

    First for the situation:
    I have a customer who wants to use apples mobileMe Service.
    For this some name server entries have to be changed.
    An CNAME entry for www pointing to should be created.
    As in the domain already an A record for www is existing i deleted this first and cleard the trash bin.
    Then I tried setting up a CNAME entry with host=www and target
    For this I get an error message: Für diesen Host existiert schon ein A-Record in dieser Zone. (For this host an A-Record is already existing).
    I rechecked the trash bin already and searched the files in /etc/bind/ for this entry but could not find one.
    If I check the nameserver with dig for www I get an correct answer for an existing entry.

    Any hint on that? Another problem is that I can not recreate the A-record for www either.

    In hope of help ...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The old a records has not been deleted from the recycle bin, most likely you did not wait with emptying the recycle nbin until ispconfig has written the changes to disk. PLease empty all recycle bin's in the dns manager again.
  3. Spaetzle

    Spaetzle Member HowtoForge Supporter

    Hi till

    Negativ. I just rechecked all available trash bins ... there is nothing in.
    I tried to create the CNAME another time as well as a new A-Record with no luck. The problem seems to be somewhere else ...
    Always the same error message.
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you still see the record in the ISPConfig database?
  5. Spaetzle

    Spaetzle Member HowtoForge Supporter


    I looked into the db. But I am not sure i exactly understand where to search for.
    Is there a documentation of the tables available somewhere?

    I found the Domain name of the given site in dns_isp_dns. When I search for the appropriate doc_id in table "dns_dep" I found two entries with child_doc_type 1018. Checking for th aproppiate child_doc_ids in table dns_a shows one entry with www as host and one with www2. Both entries existed in the past but where deleted in the ispconfig backend.
    If the info is intresting: The tabel del_status is empty.
  6. Spaetzle

    Spaetzle Member HowtoForge Supporter

    As in the meantime the domain wasn't reachable wit www.domain.tld I deleted the whole Record and recreated it for the domain. After that I was able to add appropriate CNAME.
    It seems, that something went wrong with deleting the entries in the domain.
    I hope I do not run into other troubles now.

Share This Page