Setting up Subversion and websvn on Debian / other ssh port

Discussion in 'HOWTO-Related Questions' started by lolox, Aug 12, 2008.

  1. lolox

    lolox New Member


    i read your howto about "Setting up Subversion and websvn on Debian"(

    now i'am @step

    $ mkdir ~/TEMP/
    $ echo "testing svn" > ~/TEMP/testing.txt
    $ svn import -m "importing test over ssh+svn" ~/TEMP/ svn+ssh://
    $ svn co svn+ssh:// testcheckout
    the error:
    ssh: connect to host port 22: Connection refused
    svn: Netzwerkverbindung wurde unerwartet geschlossen

    how i can use subversion with other ssh port?

    sorry for bad english, but here is german :/

    the next problem is, i used apache2 +php5

    # apt-get install enscript
    # apt-get install websvn
    [email protected]:~/test# apt-get install websvn
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    gettext intltool-debian libapache2-mod-php4 libzzip-0-12 php4 php4-common po-debconf
    Vorgeschlagene Pakete:
    gettext-doc php-pear
    Empfohlene Pakete:
    Die folgenden Pakete werden ENTFERNT:
    Die folgenden NEUEN Pakete werden installiert:
    gettext intltool-debian libapache2-mod-php4 libzzip-0-12 php4 php4-common po-debconf websvn
    0 aktualisiert, 8 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
    Es müssen 4274kB Archive geholt werden.
    Nach dem Auspacken werden 5661kB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]?

    the installer will install php4 and remove my php5 but i need php5! what i can do to don't install php4?
    Last edited: Aug 12, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    svn co svn+ssh://[B][COLOR="Red"]:1234[/COLOR][/B]/var/svn-repos/project_zen/trunk
    where 1234 is your port number.

    apt-get install websvn libapache2-mod-php5
  3. vheadz

    vheadz New Member

    sry for entering the thread, but im also a bit stucked within your little tutorial.
    i could follow until ive got the same problem as the threadstarter, helped myself with the installation of openssh (helped). but from this point on there are some problems (for me):
    you mention "htpasswd2" which im not able to find on my fresh installed system (nor in the synaptic packetmanager).
    I tried then htpasswd, which worked, somehow, still leaving me with the feeling i miss something important.
    Next one is /etc/init.s/apache2 restart
    which is denied ("Datei nicht gefunden") as normal user or root
    Next then is the sec. import (svn import -m.....) where i ve got "command not found" , possible related to the first fail, but even when restarting the apache by hand it doesnt show success...
    anyway, its a new fresh installed Debian (as Desktop, from the netinstall)
    inside the virtualbox 3.1.2 on a Macbook Pro (mid 2009)

    any hint highly appreciated,
    thx in advance

  4. falko

    falko Super Moderator ISPConfig Developer

    The correct command is
    /etc/init.[B][COLOR="Red"]d[/COLOR][/B]/apache2 restart

Share This Page