Setting up Slave server.. SQL issue.

Discussion in 'Installation/Configuration' started by mrmookie, Dec 31, 2010.

  1. mrmookie

    mrmookie New Member

    Hey Guys,

    Great software, I've been using ISPconfig now for a while on a single machine flawlessly.

    I'm currently trying to add a second slave server and attach it as your instructions state. I followed the "Perfect Ubuntu 10.10 Server instructions" here on howtoforge and updated the correct files from there.

    The master server is great and runs with no problems.

    When installing ispconfig for the slave I follow your instructions from a few of your responses and this is what I try:

    Installation mode (standard,expert) [standard]: expert
    Full qualified hostname (FQDN) of the server, eg server1.domain.tld  []:
    MySQL server hostname [localhost]:
    MySQL root username [root]: root
    MySQL root password []: ********
    MySQL database to create [dbispconfig]:
    MySQL charset [utf8]:
    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: y
    MySQL master server hostname []: and/or IP address
    MySQL master server root username [root]: 
    MySQL master server root password []: ********
    MySQL master server database name [dbispconfig]:
    Unable to connect to mysql server
    MySQL master server hostname []:

    When I type the following into the Master server:
     netstat -tap | grep mysql 
    I get
    tcp        0      0 server1.change:mysql server2.change:42338 TIME_WAIT   -
    So it's actually trying to connect to the SQL server but telling me it's unable to connect. Where should I be looking for error logs? Any help would be great.

    Thanks in advance.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The root user permissions on the master server are not correct. Please add a new records to the mysql user table on the master server as it is described in the multiserver manual, one for the IP of the slave and one for the hostname of the slave. Then restart mysql on the master and try to install ispconfig on the slave again.

Share This Page