Setting up Roundcube

Discussion in 'General' started by bve32k, Nov 19, 2006.

  1. bve32k

    bve32k New Member

    I followed the tutorial on how to setup roundcube with webmail.bve32k.org..but I can't get it working. I got stuck on a couple parts on it..

    On this part why am I replacing virtuser_file with smtp_user? If I do this then there will be 2 virtuser. And then there will be no smtp_user.

    And on this part what do I do?

    If you go to the website it doesn't show anything. I have a forward setup.
    http://webmail.bve32k.org or http://www.bve32k.org/webmail/

    Thanks, Ken
     
  2. Hans

    Hans Moderator ISPConfig Developer

    The right text must be:

    Change the line $rcmail_config['virtuser_file'] = '';

    into

    $rcmail_config['virtuser_file'] = '/etc/postfix/virtusertable';

    But we found out here: http://www.howtoforge.com/forums/showthread.php?t=8036&highlight=roundcube that if we do so, the identitiy settings will not be saved in case you login with [email protected].

    So my advise for this moment is leave the line:

    $rcmail_config['virtuser_file'] = '';

    AND

    $rcmail_config['smtp_server'] = '';

    untouched.


    -----
    chown -R www-data:www-data temp
    chown -R www-data:www-data logs

    You set the Apache permissions, so it can write to the directories temp & log, which is necesarry.

    I hope this information is helpful to you to setup RoundCube successfully!
    The howto will be updated today.
     
    Last edited: Nov 19, 2006
  3. bve32k

    bve32k New Member

    I changed the roundcube information back to what you told me.

    The chown -R I am still lost on. I should be changing www-data:www-data? right? If so to what?

    I tried going to the webmail and it wouldn't go still.. Still a white page.
     
  4. Hans

    Hans Moderator ISPConfig Developer

    When you are within your RoundCube /web directory (where you see the directories temp and log), you should perform the commands:

    chown -R www-data:www-data temp
    chown -R www-data:www-data logs

    Note: the user/group www-data is for Debian systems.
    I do not know which distro you have...
    I believe the command on Red Hat systems like Centos & Fedora is:

    chown -R apache:apache temp
    chown -R apache:apache logs

    --
    About your blank page:

    - Did you remove the .htaccess file within your web?

    - If you are using the Maildir format on your server, you have to enable Maildir within ISPConfig under Management > Settings > Email

    - Have also a look here: http://www.howtoforge.com/forums/showthread.php?t=7168&highlight=roundcube blank login
     
    Last edited: Nov 19, 2006
  5. bve32k

    bve32k New Member

    I am using Fedora 6. I will give that chown -R command a try. Yes I did remove the .htaccess files..And I did change that option in Management for the maildir. Still blank.

    Edit: I gave those commands a try and it worked all good.

    I got it working somehow. Instead of doing everything at command prompt I downloaded it with firefox and extracted the files into the directory I wanted them to go in and then it started working fine. I followed the rest of the tutorial and it seems to be working now..that was weird..

    I tried sending a test message and it didn't send. It came back and said..
     
    Last edited: Nov 19, 2006
  6. Hans

    Hans Moderator ISPConfig Developer

    Ok then. I'm happy for you that you did it!
    :)
     
  7. bve32k

    bve32k New Member

    I followed the LAMP server tutorial on how to setup everything. When I set up email did I create my own pop and smtp server? Or do I use my ISP? If I do use my own would it just be bve32k.org?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    yes.

    Thats up to you. If your server is on a DSL line, I recommend to use the mailserver of your ISP as mailrelay.

    Yes, if thats the domain of your server and bve32k.org points to the IP address of your server.
     

Share This Page