setting up roundcube to work

Discussion in 'Installation/Configuration' started by crypted, Feb 24, 2011.

  1. crypted

    crypted New Member

    Allright, I have installed roundcube and configured it successfully. However, it automatically logs out at the beginning of any session. Apparently, php.ini needs to have "session.auto_start" disabled. I don't want to disable that for every website. How can I disable it just for roundcube webmail?

    Roundcube is accessed like squirrelmail is. I moved the symlink for squirrelmail to /webmail/squirrelmail/. Roundcube is /webmail/roundcube/. I'm not sure where to edit the directives and php.ini settings for just the /webmail/ since there isn't a vhost for that.

    Help appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you installed roundcube in a website that you created in ispconfig. Then go to the options tab of the website settings and add the required php.ini settings in the php.ini field of that website.
  3. crypted

    crypted New Member

    Well, what I'm doing is using the /var/www/webmail/ and not a particular website.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you cant set specific php.ini settings. I recommend that you remove roundcube there, then create a nwe website like webmail.yourdomain.tld in ispconfig and install roundcube into that website. I have used this setup on several servers of our customers and roundcube incl. the ispconfig addon works fine that way.
  5. 8omas

    8omas Member HowtoForge Supporter

    I recently did the same thing as you. I removed squirrelmail and installed roundcube from debian repositories (apt-get install roundcube).

    It works fine
    The only thing I changed is the variable
    auto_create_user = TRUE;
    in the file /var/lib/roundcube/config/

    The "session.auto_start" disabled or not in php.ini, has no impact.

    I don't know. Maybe this is a old version of roundcube, but the whole set up is working like a charm. Every site has a /webmail pointing to round cube.
  6. crypted

    crypted New Member

    Unfortunately, changing that variable didn't work.

    Basically, a user can log-in to roundcube and see their Inbox just fine. But, it logs them off automatically after around 3 seconds.
  7. 8omas

    8omas Member HowtoForge Supporter

    Do you have Suhosin installed?
    There are a lot of posts around talking about it and the problem that you mention. They solve the problem with a .htaccess file

Share This Page