Setting up pop3-imap server

Discussion in 'Server Operation' started by redem, Mar 15, 2008.

  1. redem

    redem New Member

    I have serious problems with Dovecot IMAP/POP3 server and Sendmail...
    I have installed through Webmin Sendmail and through ssh dovecot-common, dovecot-pop3d and dovecot-imapd, ok, now, sendmail and dovecot is running, but i can't receive/send e-mails.
    I have set the record MX from my ISP DNS Control Panel (i can only set A records MX records and CNAME records, the NS records are pointed on ns1.myisp.tld and ns2.mysql.tld) to my VPS IP.

    Please, help me,
    Thanks.

    PS: Sorry for my bad english :D
     
  2. topdog

    topdog HowtoForge Supporter

    what errors do you see in the logs
     
  3. redem

    redem New Member

    here the content of /var/log/mail.log

    Code:
    Log removed :)
    
    Mail.warn

    Code:
    Log removed :)
    
    PS: I can send mail to a tiscali.it email account, but this not work with hotmail or others :|
     
    Last edited: Mar 16, 2008
  4. redem

    redem New Member

    no suggestions? :(
     
  5. topdog

    topdog HowtoForge Supporter

    Please try to post the part of the logs when you are actually sending mail out.
     
  6. redem

    redem New Member

    Sorry, i'm a newbie XD...
    however, here the last operation:

    mail.log

    Code:
    Log Removed
    
    Is correct or you need other log files?
     
    Last edited: Mar 23, 2008
  7. topdog

    topdog HowtoForge Supporter

    We that shows that the mail has been sent.
     
  8. redem

    redem New Member

    ye, but i don't see the mail on my hotmail account :confused:

    PS:
    I also tried with Postix, but with the same problem, maybe the MX Record is not set correctly?
     
    Last edited: Mar 16, 2008
  9. redem

    redem New Member

    ok, now i can send email to others e-mail accounts (like gmail) but not hotmail (??)...and i dont know why...
    However, i can't receive the mails......please, help me :(

    configuration: dovecot and sendmail (default configuration through Webmin)

    PS: With Postfix i can receive emails, but i need sendmail :)
     
  10. falko

    falko Super Moderator

    These threads might help:
    http://www.howtoforge.com/forums/showthread.php?t=18317&highlight=hotmail
    http://www.howtoforge.com/forums/showthread.php?t=11725&highlight=hotmail
    http://www.howtoforge.com/forums/showthread.php?t=20497&highlight=hotmail
    http://www.howtoforge.com/forums/showthread.php?t=16891&highlight=hotmail
    http://www.howtoforge.com/forums/showthread.php?t=17296&highlight=hotmail

    Any errors in your mail log? What's in /etc/postfix/main.cf?

    Why? Postfix is 100% compatible with Sendmail.
     
  11. redem

    redem New Member

    ...i'm pretty confused...
    on my ISP DNS Control Panel i can set only A, MX and CNAME record, i must setup a TXT record, i have installed BIND9 on my server, how it's work?

    sorry for the newbie-question but i want learn :)
     
  12. falko

    falko Super Moderator

    Ask your registrar if it's possible to set up an SPF record for your domain.
     

Share This Page