Setting up Bind on CentOS 5.2 simplified webservers setup newb question.

Discussion in 'HOWTO-Related Questions' started by tritone, Sep 1, 2008.

  1. tritone

    tritone New Member

    So I followed the simple setup guide for Bind/Apache on Centos as posted here -> BIND is setup with chroot as well, I made the symlinks as recommended and double checked them a few times.

    I got everything configured per the tutorial... I think, but when I try and set my domain's ( name servers to my newly created DNS server I get this error:

    "Unable to update nameservers: Nameserver [] doesn't exist at the registry "

    A little more about my setup that may be the cause of the problem. I have Quest DSL and the servers IP address is set to my local network address, I opened the ports on the DSL modem/router to allow in traffic for DNS, SSH, FTP, and web(port 80). I can SSH to my server in from outside my local network to the IP address quest gives me so opening those ports seems to direct traffic where it should. I am not sure if that is what I should be setting in my zone file for an ip, currently I have the internal network IP's?

    Here is my zone file per my first many tries, oh and named does start without complaining:

    $TTL 14400
    @ 86400 IN SOA [email protected]. (
    2008021501 ; serial, todays date+todays
    86400 ; refresh, seconds
    7200 ; retry, seconds
    3600000 ; expire, seconds
    86400 ) ; minimum, seconds
    psychpdx. 86400 IN NS
    psychpdx. 86400 IN NS
    ns1 IN A
    ns2 IN A IN A IN A IN MX 0
    mail IN CNAME
    www IN CNAME
    ftp IN A

    Any ideas where to start troubleshooting this? Sorry if this is super basic but I am pretty new to this stuff.


    This site is amazing by the way :)
  2. tritone

    tritone New Member

    I think I figured out my problem, I need to register my domain name at my registrar as a name server, which makes sense with the error. Like I said I am new here :)

Share This Page