Setting Up A PXE Install Server For Multiple Linux Distributions With Ubuntu Edgy Eft

Discussion in 'HOWTO-Related Questions' started by flashback_pa, Jun 22, 2007.

  1. flashback_pa

    flashback_pa New Member

    Hi, my name is Roberto and i'm writing to you cause of your "Setting Up A
    PXE Install Server For Multiple Linux Distributions With Ubuntu Edgy Eft"
    guide that i've found on Howto forge.
    I have the same problem since Fedora Core 1, and i wasn't able to solve
    it, even if i'm not completely a noob with linux.
    The problem is this: after that the computer starting up receive the ip
    address from the server (and the dhcp server is in fact perfectly working),
    then pxelinux starts, declare its ip number, and then after "TFTP prefix:"
    it starts searching for pxelinux.cfg/mac address, pxelinux.cfg/mac address
    minus last symbol and so on till pxelinux.cfg/default and then "Could not
    find kernel image linux". I can assure you the default file is under the
    pxelinux.cfg directory, but it seems that it's not readable. I was trying to
    chmod everything, 777, 444 and so on but with no results. Will you please
    try to help me ?
    Thanks in advance, Roberto.

    P.S. in var/log/messages there's also this:
    Jun 18 01:49:58 flashback dhcpd: DHCPREQUEST for 172.16.0.72 (172.16.0.1)
    from 00:0c:29:91:48:56 via eth1
    Jun 18 01:49:58 flashback dhcpd: DHCPACK on 172.16.0.72 to
    00:0c:29:91:48:56 via eth1
    Jun 17 23:49:58 flashback tftpd[15406]: RRQ from 172.16.0.72 filename
    pxelinux.0
    Jun 17 23:49:58 flashback tftpd[15406]: tftp: client does not accept
    options
    Jun 17 23:49:58 flashback tftpd[15407]: RRQ from 172.16.0.72 filename
    pxelinux.0
    Jun 17 23:49:58 flashback tftpd[15408]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/01-00-0c-29-91-48-56
    Jun 17 23:49:58 flashback tftpd[15409]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC100048
    Jun 17 23:49:58 flashback tftpd[15410]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC10004
    Jun 17 23:49:58 flashback tftpd[15411]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC1000
    Jun 17 23:49:58 flashback tftpd[15412]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC100
    Jun 17 23:49:58 flashback tftpd[15413]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC10
    Jun 17 23:49:58 flashback tftpd[15414]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC1
    Jun 17 23:49:58 flashback tftpd[15415]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/AC
    Jun 17 23:49:58 flashback tftpd[15416]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/A
    Jun 17 23:49:58 flashback tftpd[15417]: RRQ from 172.16.0.72 filename
    pxelinux.cfg/default
    Jun 17 23:49:58 flashback tftpd[15418]: RRQ from 172.16.0.72 filename
    linux
    Jun 17 23:49:58 flashback tftpd[15419]: RRQ from 172.16.0.72 filename
    linux.cbt
    Jun 17 23:49:58 flashback tftpd[15420]: RRQ from 172.16.0.72 filename
    linux.0
    Jun 17 23:49:58 flashback tftpd[15421]: RRQ from 172.16.0.72 filename
    linux.com
    Jun 17 23:49:58 flashback tftpd[15422]: RRQ from 172.16.0.72 filename
    linux.c32
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  3. sinj

    sinj New Member

    Hi,

    I have a working PXEboot install server (SunOS 5.10) with Ubuntu 7.10 Gutsy and Ubuntu 8.04 Hardy distros. I can sucessfully install these distros even with automated kickstart config but I want to add an OpenBSD netboot kernel too.
    Is it possible?
    How should I edit pxelinux.cfg/default file to boot openbsd?
    Yes I have a working openbsd netboot kernel but I have to manually edit the dhcpd.conf to boot the bsd kernel when a bsd install needed.


    THX
     

Share This Page