Setting up a media server (Hardy Heron)

Discussion in 'HOWTO-Related Questions' started by aclivity, Jul 4, 2008.

  1. aclivity

    aclivity New Member

    Hi There

    I'm an Ubuntu / Linux novice, so I apologise in advance if my questions are a bit basic. I've been given an old PC with the intention of finding out if I can use it as a server, with my music streamer in particular. I've installed Hardy Heron, and have been trying to follow the instructions here:

    I followed this step and it worked fine:
    but when I tried to carry out the dpkg step, the following occurred:
    [email protected]_USER-server:~$ dpkg -i fuppes_0+svn611-1_i386.deb
    dpkg: requested operation requires superuser privilege
    [email protected]_USER-server:~$ 
    sudo dpkg -i fuppes_0+svn611-1_i386.deb
    [sudo] password for MY_USER: 
    Selecting previously deselected package fuppes.
    (Reading database ... 120071 files and directories currently installed.)
    Unpacking fuppes (from fuppes_0+svn611-1_i386.deb) ...
    dpkg: dependency problems prevent configuration of fuppes:
    fuppes depends on libgif4 (>= 4.1.6); however:
      Package libgif4 is not installed.
    fuppes depends on libmagick++10; however:
      Package libmagick++10 is not installed.
    fuppes depends on libsimage20; however:
      Package libsimage20 is not installed.
    fuppes depends on libswscale1d (>= 0.cvs20070307); however:
      Package libswscale1d is not installed.
    dpkg: error processing fuppes (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    No problem I thought - I will simply download those packages (libgif4, libmagick++10, libsimage20 and libswscale1d) and install them myself. I found a suitable mirror site and chose to open the first file from the location using package installer, only to be presented with the following message:

    Am I doing something really fundamentally wrong? Is this a common Ubuntu newbie type mistake?

    All advice greatfully received.


  2. topdog

    topdog Active Member HowtoForge Supporter

    why dont you use apt to install your packages it will fix the dependencies

Share This Page