Setting ssh users to inactive does not work

Discussion in 'General' started by jumba, Jul 18, 2010.

  1. jumba

    jumba New Member

    I use Ubuntu 10.4 and ISPConfig 3.0.2.2.
    Setting the ssh users to inactive does not work. I can still connect with those users after the active/inactive job has disappeared from the Jobqueue.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are the users jailed or not?
     
  3. jumba

    jumba New Member

    I have 4 users. 2 of them are jailed, 2 are not.

    The inactive users who are jailed can connect but are jailed in /home/username.
    They can not enter in the /web directory

    The inactive users who are not jailed can connect and enter in any directory.

    But is a user is inactive (nonexistent), shouldn't that prevent the connection from being established in the first place?
     
  4. jumba

    jumba New Member

    It seems that's true only if I connect with sftp (with Filezilla).
    If I connect with ssh, start mc and try to exit /home/username I get an error but then I am able to exit /home/username and enter any folder within the original jail, including /web

    Another issue:

    After setting a jailed user to inactive and then back to active, and connecting with sftp (with Filezilla), that active user can't exit /home/username anymore.
    So an active (jailed) user connected with sftp has no access to /web or other directories anymore.
    The trick is to connect with ssh and start mc, like I said.
     
    Last edited: Jul 18, 2010
  5. jumba

    jumba New Member

    Any suggestions?
    Thanks
     
  6. jumba

    jumba New Member

    This is a bug. Hopefully it will be fixed in the next version.
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If you think that there is a bug, then report it to the bugtracker.
     

Share This Page