Setting Signalfile Failed: update

Discussion in 'Installation/Configuration' started by SupuS, Feb 13, 2008.

  1. SupuS

    SupuS HowtoForge Supporter

    Hi guys

    I installed ispconfig 2.2.20 (and install new file from 2.2.21) on new Ubuntu 7.10 server and everythink was ok. But now new configuration is not writen .. if I change anything in /home/admispconfig/ispconfig/ispconfig.log is only:

    Code:
    13.02.2008 - 12:18:10 =>  - Setting Signalfile Failed: update
    If I run /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php manually so configuration is writen and I get this lines:

    Code:
    start
    UPDATE: 2
    UPDATE: 3
    INSERT USER: 5
    INSERT USER: 6
    
    Warning: symlink(): File exists in /root/ispconfig/scripts/lib/config.lib.php on line 933
    UPDATE USER: 3
    
    Warning: symlink(): File exists in /root/ispconfig/scripts/lib/config.lib.php on line 933
    UPDATE USER: 4
    ende
    
    Any idea how to solve it or where looking for the bug?

    edit: This thing happend to me in version 2.2.20 but I reinstalled whole 2.2.20 and it disappears .. but now it is back again :(

    edit 2: Now I found this in ispconfig log (after using manually writeconf):

    Code:
    13.02.2008 - 12:54:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    13.02.2008 - 12:54:02 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
    Thanks .. SupuS
     
    Last edited: Feb 13, 2008
  2. SupuS

    SupuS HowtoForge Supporter

    Here is complete outoput of /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php in ispconfig log after adding some more test users:

    Code:
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 257: WARNING: could not setquota -g web3 1024000 1025024 0 0 -a &> /dev/null
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 258: WARNING: could not setquota -T -g web3 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 277: Connected successfully
    13.02.2008 - 14:12:02 => INFO - USER:
    web3test:x:10014:10013:Petr test:/var/www/web3/user/web3test:/bin/false
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test 0 0 0 0 -a &> /dev/null
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test/.forward
    13.02.2008 - 14:12:02 => INFO - USER:
    web3test:x:10016:10013:test:/var/www/web3:/bin/false
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test 0 0 0 0 -a &> /dev/null
    13.02.2008 - 14:12:02 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/.forward
    13.02.2008 - 14:12:02 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 117: symlink /var/www/web3/Maildir
    13.02.2008 - 14:12:03 => INFO - USER:
    web3:x:10018:10013:Prodej:/var/www/web3/user/web3:/bin/false
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3 0 0 0 0 -a &> /dev/null
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3/.forward
    13.02.2008 - 14:12:03 => INFO - USER:
    web3test3:x:10021:10013:Dotaz:/var/www/web3/user/web3test3:/bin/false
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test3 0 0 0 0 -a &> /dev/null
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test3 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test3/.forward
    13.02.2008 - 14:12:03 => INFO - USER:
    web3test2:x:10023:10013:test2:/var/www/web3/user/web3test2:/bin/false
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 905: WARNING: could not setquota -u web3test2 0 0 0 0 -a &> /dev/null
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 906: WARNING: could not setquota -T -u web3test2 604800 604800 -a &> /dev/null
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web3/user/web3test2/.forward
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    13.02.2008 - 14:12:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
    13.02.2008 - 14:12:03 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1259: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
    13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
    13.02.2008 - 14:12:04 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2018: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
    13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
    13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
    13.02.2008 - 14:15:01 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
    13.02.2008 - 14:15:01 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1259: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
    13.02.2008 - 14:15:02 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2018: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
    
    Running of commands from WARN lines in command line is without errors
     
  3. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -l /bin/sh
    ?
     
  4. SupuS

    SupuS HowtoForge Supporter

    Hi Falko

    Thanks for replay. Here is command output:

    Code:
    #ls -l /bin/sh
    lrwxrwxrwx 1 root root 9 Feb  8 22:17 /bin/sh -> /bin/bash
    
    Yesterday I found that Ubuntu 7.10 probably has build in AppArmor feature. From /var/log/messages:

    Code:
    AppArmor: AppArmor initialized<5>audit(1202899231.350:2):  type=1505 info="AppArmor initialized" pid=1055
    So I disabled it as described on https://help.ubuntu.com/community/AppArmor and reinstalled ispconfig again. Unfortunately AppArmor was up again after restart even if I disabled it as described on help page. I have to kill it before installation.
    For now it seems ok but will see for some more testing. After last reinstallation it was ok too but next day error was back.

    With disabling AppArmor gone away follow bind error message too:

    Code:
    Failure registering capabilities with primary security module.
     
  5. falko

    falko Super Moderator

    Did you disable AppArmor using update-rc.d?
     
  6. SupuS

    SupuS HowtoForge Supporter

    Yes I used

    Code:
    update-rc.d -f apparmor remove
    but apparmor still alive next boot .. so I killed it by

    Code:
    /etc/init.d/apparmor kill
     
  7. falko

    falko Super Moderator

    Do you see apparmor links in /etc/rc2.d, /etc/rc3.d, and /etc/rc5.d?
     
  8. SupuS

    SupuS HowtoForge Supporter

    No. Will see after next reboot. I hope it will not start never more :)
     
  9. SupuS

    SupuS HowtoForge Supporter

    So .. Setting Signalfile Failed: insert error is back again .. now I am almost sure that it is because of awstats plugin by djtremors on

    http://www.djtremors.com/index.php?option=com_content&task=view&id=25&Itemid=139

    Have anybody similar problem with ispconfig 2.2.21 and this mode? After latest reinstall of 2.2.21 I forgot install awstat mode too .. and everything was ok .. today I found that stats not works .. so I installed awstat mode, generated statistics and error message is back again :(

    Only one difference .. no WARN in /home/admispconfig/ispconfig/ispconfig.log .. only this line:

    Code:
    - Setting Signalfile Failed: insert
    Any help welcome .. thanks SupuS
     
    Last edited: Feb 27, 2008
  10. falko

    falko Super Moderator

    Did you check if AppArmor is still switched off?
     
  11. SupuS

    SupuS HowtoForge Supporter

    Hi Falco

    Yes I checked apparmor and it is still off. In past time error comes next day after install .. so I think it was due to awstats mode and its automatic run by cron at night.
    In next two days I will try install awstats mode again and test if error come again. For this time everything run smoothly (without awstats mode).

    Now I checked differences between new root and home directories and backuped one by diff utility. No differences was found except /root/ispconfig/scripts/shell/awstats.php as expected. Some differs between some binary files (ispconfig_httpd and libphp5.so for example) was found too but it is probably normal.
    So I think that awstats .. if is it a culprit .. change permission on some files or kill some new function of ispconfig .. but it is still only idea ..
     
  12. radim_h

    radim_h Member

    Not Caused by App Armor

    That wasnt caused by Apparmor, i don't use it
    but exactly same thing happened to me on Debian Etch 64bit yesterday, when i installed DJTremors AWstats plugin 1.4.1
    I had to wipe out anything regarding AWstats and reinstall whole ISPconfig...
    After it, i still cannot use ISPC built-in firewall (something happened to Bastile) and whole system seems to be touched somehow...
    Thanks god, i was going to migrate whole server to new hardware anyway next week...

    It is sad i used really like to use DJTremors plugin and i'd like to use it still, but don't want to take risk and try again..

    SupuS d you stil luse DJTremors awstats, , which version and how did you managed it?
     
    Last edited: Apr 2, 2008
  13. djtremors

    djtremors ISPConfig Developer

    my script/installation doesn't tamper with ispconfig db. Only SELECTs as per webalizer.php so if it effected it in some how, it would be interesting to see exactly how....
     
  14. swieep

    swieep New Member

    21.02.2008 - 15:37:33 => - Setting Signalfile Failed: insert
    21.02.2008 - 15:37:44 => - Setting Signalfile Failed: insert
    21.02.2008 - 15:45:41 => - Setting Signalfile Failed: insert

    02.04.2008 - 14:33:23 => - Setting Signalfile Failed: update
    02.04.2008 - 14:34:36 => - Setting Signalfile Failed: update
    02.04.2008 - 14:35:12 => - Setting Signalfile Failed: update

    Same problem here (as of 21.02.2008) do not use apparmor or have it installed.

    updatedb and locate apparmor did not find any result.

    I do use awstats, but can not imagine why this should give problems?..

    Searched this forum and found only the apparmor solution but it does not fix my problems.. for now I run the writeconf.php manually but this is not workable..

    I do not receive errors or warnings when I run the script by hand.. just:

    start
    UPDATE: 20
    UPDATE: 46
    UPDATE: 63
    INSERT USER: 207
    INSERT USER: 197
    INSERT USER: 206
    INSERT USER: 208
    INSERT USER: 209
    INSERT USER: 210
    UPDATE USER: 38
    UPDATE USER: 83
    UPDATE USER: 78
    UPDATE USER: 79
    UPDATE USER: 80
    UPDATE USER: 81
    UPDATE USER: 175
    ende
     
  15. SupuS

    SupuS HowtoForge Supporter

    This problem solved itself for me after last reinstall of ISPConfig. I didn't install awstats by install script but only copy awstats.php to /root/ispconfig/scripts/shell from backup. Rest of the awstats mode files remain from previous installation.
    After that I switched on apparmor too .. and everything run ok.

    EDIT: 2radim_h: yes I use last version of DJTremors awstats mode with ISPConfig 2.2.21
     
    Last edited: Apr 2, 2008
  16. Mouton

    Mouton New Member

    Hello everybody!

    I had the same problem and .. you were right. Awstats extracts files in many folders, changing rights to the user you were (root because you need to be root).

    To solve the problem, change back the rights of the fallowing folders/files to admispconfig:admispconfig (if you did install with this user:group)

    home/admispconfig/
    home/admispconfig/ispconfig/
    home/admispconfig/ispconfig/sysconf.txt
    home/admispconfig/ispconfig/users
    home/admispconfig/ispconfig/adminmail.txt
    home/admispconfig/ispconfig/web/

    (I'm not sure about the files (not folders) rights)

    See ya.
     
  17. radim_h

    radim_h Member

    so basically:
    chown -R admispconfig:admispconfig /home/admispconfig ?
     
  18. Mouton

    Mouton New Member

    Some of the files in sobfolders may not be owned by admispconfig or not of the admispconfig group. The folders listed are the ones that are modified by the archive. So I would not use -R option. But.. could work as well ... ?
     
  19. falko

    falko Super Moderator

    That should work.
     

Share This Page