Setting Firewall rules blocks all incoming traffic

Discussion in 'Installation/Configuration' started by Nap, Jan 24, 2015.

  1. Nap

    Nap Member

    I setup a test server today from scratch, but instead of using MySQL, I used MariaDB.
    All the services are working (phpmyadmin, http, & https), as well as ISPConfig.

    I then went into System -> Firewall and used the Add Firewall Record button to add a rule set (there weren't any entries initially). I added the default list of TCP/UDP ports, and immediately after I saved the rule, the whole server became externally inaccessible. Even ping was being blocked with a "host unreachable" error, whilst I could still ping lan clients from the server.

    To regain external access, I had to log into the server through its consol and clear the iptables rule set maunally. (This is obvously now what I want.) After clearing the iptables rules, the server could again be accessed from the other clients on my lan. But if I again saved the Firewall Record with the default ports, the above problem would recur and I would have to again login and clear the rules.

    This is obviously a strange behaviour and the first time somthing like this has happened to me.

    Has this happened to anyone before? What could be the source of the problem?

  2. Nap

    Nap Member

    The problem was that I had left the firewall type in the Server Config section on Bastille, rathar than ufw (which is what I'm using).

    All working now :)

Share This Page