set up DNS behind a router

Discussion in 'Installation/Configuration' started by -crisstm-, Aug 17, 2008.

  1. -crisstm-

    -crisstm- Banned

    Hi all,

    I have an public IP 89.122.18.58, and behind the router on my server i have IP 192.168.1.65. i try all possibilies but doesn't work my web site www.diasfast.ro. its working in my internal network's fine but i can't see from external
    thank's
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you use the external IP addresses and not the internal IP's in the ispconfig DNS manager.
     
  3. -crisstm-

    -crisstm- Banned

    Hi Till

    Under ISPConfig DNS MAnager i have set the public IP at tab domain, and tab option i have also Public IP twise (at ns1 and ns2 too), and under records i set up both host www, one with private IP and other with the public IP.where i am wrong?
     
  4. gdaddy

    gdaddy New Member

    1. Your internal IP address looks suspiciously like a DHCP range. It should be fixed, and if it is fixed it shouldn't overlap with DHCP addresses. This isn't the cause of your current problem, but will probably cause your next one.

    2. Your domain shows as registered to your DNS server - so thats a start.

    3. NSLookup and Reverse Lookup both fail. This probably means your router is blocking incoming requests on ports 53 for DNS. It's clearly not communicating with the outside world.

    Depending on your network setup, and I suspect by the sounds of things you have a single IP address being shared with your router you will need to open up the relevant ports - at least TCP ports 80 and 53 incoming - and ensure your router knows to forward those requests to your server. Optional will be if you want mail then 25, and if you want access to mail from outside your network port 110. ISPConfig is 81, FTP 21 (although routers might need 20 as well because FTP can be a bit weird), SSH 22.

    There are so many different types of router I can't really tell you anymore, if it is a cheap DSL one, look for features called DMZ, Port Forwarding, Access & Gaming. On more expensive ones it will be part of a firewall setup, ACL or possibly called VIP or SIP.
     
  5. -crisstm-

    -crisstm- Banned

    port

    hi
    i work with router ADSL Speedtouch516, and all port is forward for my server wich have ip static 192.168.1.65
    DNS port 53 both tcp and udp
    ftp port 21
    smtp port25
    pop3 110
    ispconfig port 81
    http 80
    I think my problem is on isp config
    Under Management->Server->Settings->Server i have
    Hostname ns1
    Domain diasfast.ro
    IP 192.168.1.65
    IP list both IP private and public

    Under DNS tab i have at default ns1 and ns2 same IP 89.122.18.58 (public)

    on ISp Manager->sites->diasfast->basics i have
    IP 192.168.1.65

    At DNS MAnager->Domain i have
    Doamin SOA diasfast.ro
    Ip 89.122.18.58
    At Option tab i put at nameserver1 and ns2 the public ip 89.122.18.58
    and finally records tab i have
    host www with both IP public and private
    Note: the www.diasfast.ro i can see from my internal network, but from server and my internal network i can see diasfast.ro.
    when i type traceroute diasfast.ro is no host
    when i type traceroute www.diasfast.ro is found my host with my private ip.
    where i am wrong?
     
  6. gdaddy

    gdaddy New Member

    Yep you're right. The network looks good, so probably a DNS setup problem. Sorry don't know anything about DNS.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to remove the duplicate entries for the internal IP addresses. In DNS there should be only the external IP addresses.

    NS1 and NS2 must be hostanems / domains and not IP addresses.

    Have a look here for a in depth introduction into the dns system:

    http://www.howtoforge.com/traditional_dns_howto
     
  8. -crisstm-

    -crisstm- Banned

    ok

    i fixit that settings.
    In default nameserver and in nameserver 1 si 2 i have
    ns1.diasfast.ro

    at dns manager i have ip external 89.122.18.58
    but still doesn't work
    at ISP Manager at site diasfast.ro i have the internal IP 192.168.1.65
    it's corect?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server2:~# dig www.diasfast.ro
    
    ; <<>> DiG 9.3.4 <<>> www.diasfast.ro
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 44893
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.diasfast.ro.               IN      A
    
    ;; Query time: 118 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Tue Aug 19 14:21:31 2008
    ;; MSG SIZE  rcvd: 33
    
    server2:~# dig diasfast.ro
    
    ; <<>> DiG 9.3.4 <<>> diasfast.ro
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 37586
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;diasfast.ro.                   IN      A
    
    ;; Query time: 83 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Tue Aug 19 14:21:36 2008
    ;; MSG SIZE  rcvd: 29
    
    server2:~# dig ns diasfast.ro
    
    ; <<>> DiG 9.3.4 <<>> ns diasfast.ro
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 19244
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;diasfast.ro.                   IN      NS
    
    ;; Query time: 58 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Tue Aug 19 14:21:40 2008
    ;; MSG SIZE  rcvd: 29
    
    server2:~#
    IT seems you did not define any nameservers for your domain. You must do that first in the web interface of your registrar.
     
  10. -crisstm-

    -crisstm- Banned

    sorry Falko

    i have register my domain diasfast.ro at my registrar....www.rotld.ro
    if you want to see...
    you don't see my server because i will stop my server because is not working.
    i will start this server in this moment, if you wanna check again...
    thank's
     
  11. falko

    falko Super Moderator ISPConfig Developer

    The
    Code:
    dig ns diasfast.ro
    command must show the nameservers regardless of if your server's running or not. This means you've probably not defined any nameservers for the domain at your registrar.
     

Share This Page