Sessions not set after installing php 5.3.10

Discussion in 'General' started by Showa, Mar 17, 2012.

  1. Showa

    Showa Member

    My server is configurated using this howto:

    For another project I need php 5.3 and I tried to install it using this howto:

    Centos is updated to version 5.8 Final.

    Installing php 5.3 was no problem an checking with php -v gave me version 5.3.10. The problem was that afterwards users from my site couldn't log in to the memberpages.

    I made a testpage with this code:
    and refreshing this page the number didn't change. So I concluded that sessions didn't function. Downgrading to php 5.1.6 and everything worked again. The testpage also counted after refreshing.

    I really would like to use php 5.3 Do I also have to change Apache and Mysql versions, or do I have to change something in the php.ini files? Who knows a solution?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the php.ini file of the new php version, there might be a different path for saving session data set. Either change the path back to the directory that was used in php 5.1 or ensure that the new path exists and is worls writable (writable for all users).
  3. Showa

    Showa Member

    Hi Till,

    Path is the same in both ini files, permission are the same. I downgraded to 5.1.6 reinstalled phpmyadmin and squirrelmail and everything functions normally. Again upgrading to 5.3.10 and the same problem occurs.
  4. Showa

    Showa Member

    Nobody has an answer?

Share This Page