services not running - mysqld

Discussion in 'Installation/Configuration' started by fbnewtz, Aug 8, 2006.

  1. fbnewtz

    fbnewtz New Member

    I keep getting the following warning email:

    Warning: service mysqld not running (server:


    When I login to my server MySQL is running. I am running debian 3.1 I believe. The name of the file in /etc/init.d/ is mysql, not mysqld. However, whenever I do a ps -aux|grep mysqld I find three instances of MySQL running. Everything seems to be running just fine right now also.


    Any ideas?
     
  2. till

    till Super Moderator

    please post the output of:

    netstat -tap | grep mysql
     
  3. fbnewtz

    fbnewtz New Member

    output of netstat

    Here is the output to the above command.


    tcp 0 0 *:mysql *:* LISTEN 32098/mysqld

    Thanks,

    Fred
     
  4. falko

    falko Super Moderator

    Looks ok. What's in /etc/hosts? What's the output of
    Code:
    ps -aux|grep mysql
    and
    Code:
    grep mysql /etc/services
    ?
     
  5. fbnewtz

    fbnewtz New Member

    Results of commands

    Here is my /etc/hosts file:

    127.0.0.1 localhost.localdomain localhost
    1.1.1.1 sp2979a.myhostsdomain.com sp2979a
    ^ -- Of course this is my real IP.

    # The following lines are desirable for IPv6 capable hosts
    #::1 ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts


    Output of ps -aux | grep mysql
    root 32061 0.0 0.5 2740 1320 ? S Jul29 0:00 /bin/sh /usr/bin/ mysqld_safe
    root 32097 0.0 0.5 2740 1324 ? S Jul29 0:00 /bin/sh /usr/bin/ mysqld_safe
    mysql 32098 0.0 6.2 116916 16124 ? S Jul29 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/ mysqld.pid --skip-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
    root 32099 0.0 0.2 1776 548 ? S Jul29 0:00 logger -p daemon. err -t mysqld_safe -i -t mysqld
    root 9217 0.0 0.2 1832 584 pts/3 R+ 12:46 0:00 grep mysql

    Output of grep mysql /etc/services

    mysql 3306/tcp
    mysql 3306/udp


    Thanks for the help.

    Fred
     
  6. falko

    falko Super Moderator

    Looks ok, too. :confused:
    Did you try and restart the server?
     
  7. fbnewtz

    fbnewtz New Member

    Restart Server

    Not yet, but I will. Can you give me an idea of where to look in code and I will see if I can spot the problem. You don't have to tell me exactly, I just don't know which file monitors the services.

    Thanks,

    Fred
     
  8. till

    till Super Moderator

    The file is:

    /root/ispconfig/scripts/shell/check_services.php
     
  9. Mikymike

    Mikymike New Member

    Exactly the same problem same mail message in root mailbox

    Warning: service mysqld not running (server: server_name)!

    Message generated at November 25, 2006, 11:30.

    I'm runing latest ISPConfig on a Debian Sarge too with last MySQL5 and PHP5 from dotdeb stable source

    But all is runing fine.
     
  10. till

    till Super Moderator

    Please make sure your mysql server listens on a TCP socket on 127.0.0.1 too.
     
  11. talishka

    talishka New Member

    Hi people, i'm having a similar problem with mysqld (Ver 5.0.30-Debian_0.dotdeb.1-log for pc-linux-gnu on i386 (Dotdeb Sarge backport).

    I start the server everythin is working good, then someday with no reason i cannot access to my blogs because it sez that my mysql server is down.. so, i do a ps xau |grep mysqld and i see it's runnin, so i run /etc/init.d/mysql stop

    And this is what i get:

    Code:
    Stopping MySQL database server: mysqld...failed.
    /usr/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (11)'
    Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
    Killing MySQL database server by signal: mysqld...failed.
    Please stop MySQL manually and read /usr/share/doc/mysql-server/README.Debian!
    I also verified that mysqld.sock was 'running' and located in the right path.

    Finally, i have to killall mysqld, and restart the mysql daemon and everything starts to work just fine again. This is happenin since i upgraded my mysql server to version 5 of dotdeb.

    Waitin for ideas, thx in advance.
     
  12. till

    till Super Moderator

    Does this happened onece or more often?
     
  13. talishka

    talishka New Member

    Yes, in fact, this is happenin right now again.. any ideas?
     
  14. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /var/run/mysqld
    ? Have you tried to reboot your server?
     
  15. talishka

    talishka New Member

    drwxr-xr-x 2 mysql root 4096 2006-12-19 12:05 .
    drwxr-xr-x 18 root root 4096 2006-12-20 06:28 ..
    -rw-rw---- 1 mysql mysql 6 2006-12-19 12:05 mysqld.pid
    srwxrwxrwx 1 mysql mysql 0 2006-12-19 12:05 mysqld.sock

    Yes of course i've restarted the server. Now im restartin the server again.. I'm not gettin what's wrong, damn.
     
    Last edited: Dec 22, 2006
  16. falko

    falko Super Moderator

    You can try this:
    Code:
    rm -f /var/run/mysqld/*
    and then reboot your server.
     
  17. talishka

    talishka New Member

    It didn't work, but thx man ;D
     
  18. falko

    falko Super Moderator

    Then I guess there's something wrong with your new MySQL server... :( Maybe there's an updated package that you can install?
     
  19. bno10

    bno10 New Member

    I have the same problem. I receive email "service not running" every 30mn while mysql is running

    Details:
    I upgrade PHP and MYSQL from dotdeb (from mysql 4.0.24 to mysql 4.1.15)
    It works without problem during 1 week

    I restart mysql one day and the problems begins
    I think there was confusion beetween mysql 4.0.24 and 4.1.15 because it doesn't recognize 4.1.15 parameters like old_passwords and expire_log_days.

    I comment those parameters in my.cnf and it works but with 4.0.24 !
    And I receive this error email since.

    Bruno
     
  20. till

    till Super Moderator

    Please post the output of:

    netstat -tap
     

Share This Page