Services in VPS stalling - why?

Discussion in 'Server Operation' started by flameproof, Feb 1, 2009.

  1. flameproof

    flameproof Member

    I have a problem with stalling services in my VPS. I use 280Mb RAM and host 5 low traffic domains. I have stalling problems with Postfix, Dovecot, Bind/named and ProFTP.

    Postfix/Dovecot is the biggest problem since it will email impossible.

    I am not sure if services get kicked out in times of very high memory use. I disabled already ClamAV, but I like to keep Spamassassin.

    Any ideas what could it be?

    Update: I think "munin" could be handy. But it doesn't log anything. I followed this guide:

    http://www.howtoforge.com/server-monitoring-with-munin-and-monit-on-centos-5.2

    Everything installs smooth. I changed the munin.conf

    Code:
    [...]
    dbdir   /var/lib/munin
    [COLOR="Red"]htmldir /home/domain3/public_html/monitoring[/COLOR]
    logdir  /var/log/munin
    rundir  /var/run/munin
    
    # Where to look for the HTML templates
    tmpldir /etc/munin/templates
    [...]
    # a simple host tree
    [localhost] (tried also [COLOR="Red"][www.domain3.com][/COLOR]
        address 127.0.0.1
        use_node_name yes
    [...]
    The directory is there and it's 777
     
    Last edited: Feb 1, 2009
  2. DigitalLinx

    DigitalLinx New Member

    Perhaps the HW node you're on is suffering from high disk i/o, that's the most likely reason why services would be staling on a VPS enviroment. Suggest to contact your provider to take a look at that node to check who's hogging resources.
     
  3. flameproof

    flameproof Member

    I think my problems are internal. Right now I still work on Munin, with my setup above I get following error:

    Code:
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    Cannot open /home/domain3/public_html/monitoring/localhost/localhost-cpu.html at /usr/share/munin/munin-html
    line 488.
    
    It seems the [localhost] in the server tree just wants to create a directory "locahost". When I set it to:

    #[localhost]

    ...then I get:


    Code:
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    cp: accessing `/home/domain3/public_html/monitoring/': Permission denied
    Cannot open /home/domain3/public_html/monitoring/index.html at /usr/share/munin/munin-html
    line 488.
    
    All directories and files are there, all are 777 and munin:munin

    Where is the Munin error?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /home/domain3/public_html/
    ?
     
  5. flameproof

    flameproof Member


    Code:
    [[email protected] ~]# ls -la /home/domain3/public_html/
    total 344
    drwxr-x--- 18 domain3 domain3  4096 Feb  1 19:47 .
    drwxr-xr-x 12 domain3 domain3  4096 Jan 17 02:55 ..
    -rw-r--r--  1 root    root    13620 Jan  8 20:28 233.htm
    -rw-r--r--  1 root    root     1255 Jan  8 20:28 404.htm
    drwxr-xr-x  2 root    root     4096 Jan  8 20:30 CCL
    -rw-r--r--  1 root    root      454 Jan  8 20:28 INDEX_iwiz.HTM
    drwxr-xr-x  2 root    root     4096 Jan  8 20:53 LBV
    drwxr-xr-x  2 root    root     4096 Jan  8 20:54 MD
    drwxr-xr-x  2 root    root     4096 Jan  8 20:59 P3
    -rw-r--r--  1 root    root     4115 Jan 22 09:20 Sitemaps.xml
    drwxr-xr-x  3 root    root     4096 Jan  8 20:28 aspnet_client
    lrwxrwxrwx  1 root    root       31 Jan  8 20:18 awstats-icon -> /usr/share/awstats/wwwroot/icon
    -rw-r--r--  1 root    root     3396 Jan  8 20:28 ccl_d.htm
    drwxr-xr-x  2 root    root     4096 Jan  8 20:30 cgi-bin
    -rw-r--r--  1 root    root      240 Jan  8 20:28 china.gif
    drwxr-xr-x  2 root    root     4096 Jan  8 20:30 db
    drwxr-xr-x 12 root    root     4096 Jan  8 20:41 forum
    lrwxrwxrwx  1 root    root       31 Jan  8 20:18 icon -> /usr/share/awstats/wwwroot/icon
    drwxr-xr-x  2 root    root     4096 Jan  8 20:53 images
    -rw-r--r--  1 root    root      454 Jan  8 20:28 index.htm
    -rw-r--r--  1 root    root     1411 Jan  8 20:28 index_l.htm
    -rw-r--r--  1 root    root     2168 Jan  8 20:28 index_r.htm
    -rw-r--r--  1 root    root     5639 Jan  8 20:28 jap_pcb.jpg
    -rw-r--r--  1 root    root      303 Jan  8 20:28 lines.gif
    -rw-r--r--  1 root    root    15890 Jan  8 20:28 mail.htm
    -rw-r--r--  1 root    root     3945 Jan  8 20:28 main_d.htm
    drwxrwxrwx  3 munin   munin    4096 Feb  1 20:37 monitoring
    drwxr-xr-x  2 root    root     4096 Jan 22 07:06 msd
    -rw-r--r--  1 root    root     3274 Jan  8 20:28 pcb.htm
    -rw-r--r--  1 root    root     2844 Jan  8 20:28 pcb_d.htm
    -rw-r--r--  1 root    root      177 Jan  8 20:28 php.php
    drwxr-xr-x  4 root    root     4096 Jan  8 21:01 shop
    -rw-r--r--  1 root    root      986 Jan  8 20:28 slines.gif
    drwxr-xr-x  2 domain3 domain3  4096 Feb  1 05:32 stats
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    chmod 755 /home/domain3/public_html
     
  7. flameproof

    flameproof Member

    that worked. Thank you! I can access the page now, however, there is no data, I can just see:

    Overview
    This page was generated by Munin version 1.2.5 at 2009-02-03 T 02:25:04


    That page is now about 24 hours old.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in your logs? Did you restart munin?
     

Share This Page