Services attempt to assign ipv6 addresses before ready

Discussion in 'Installation/Configuration' started by Nolan, Sep 21, 2017.

  1. Nolan

    Nolan Member

    Taken from /var/log/syslog, running Debian 9. I need to run dibbler or dhclient (the behavior below occurs on both, unfortunately) before attempting to bind the addresses. If I reboot, I need to restart the services after the fact for them to work properly.

    Sep 21 00:09:43 octave ntpd[1384]: bind(25) AF_INET6 2001:bc8:3ca9:101::5#123 flags 0x11 failed: Cannot assign requested address
    Sep 21 00:09:43 octave ntpd[1384]: unable to create socket on eno1 (9) for 2001:bc8:3ca9:101::5#123
    Sep 21 00:09:43 octave ntpd[1384]: failed to init interface for address 2001:bc8:3ca9:101::5
    Sep 21 00:09:43 octave ntpd[1384]: bind(25) AF_INET6 2001:bc8:3ca9:101::4#123 flags 0x11 failed: Cannot assign requested address
    Sep 21 00:09:43 octave ntpd[1384]: unable to create socket on eno1 (10) for 2001:bc8:3ca9:101::4#123
    Sep 21 00:09:43 octave ntpd[1384]: failed to init interface for address 2001:bc8:3ca9:101::4
    Sep 21 00:09:43 octave ntpd[1384]: bind(25) AF_INET6 2001:bc8:3ca9:101::3#123 flags 0x11 failed: Cannot assign requested address
    Sep 21 00:09:43 octave ntpd[1384]: unable to create socket on eno1 (11) for 2001:bc8:3ca9:101::3#123
    Sep 21 00:09:43 octave ntpd[1384]: failed to init interface for address 2001:bc8:3ca9:101::3
    Sep 21 00:09:43 octave ntpd[1384]: bind(25) AF_INET6 2001:bc8:3ca9:101::2#123 flags 0x11 failed: Cannot assign requested address
    Sep 21 00:09:43 octave ntpd[1384]: unable to create socket on eno1 (12) for 2001:bc8:3ca9:101::2#123

    Sep 21 00:09:43 octave postfix/postfix-script[1677]: starting the Postfix mail system
    Sep 21 00:09:43 octave postfix/master[1687]: fatal: bind 2001:bc8:3ca9:101::3 port 25: Cannot assign requested address
    Sep 21 00:09:44 octave postfix/master[1682]: fatal: daemon initialization failure
    Sep 21 00:09:45 octave postfix/postfix-script[1875]: fatal: mail system startup failed
    Sep 21 00:09:46 octave systemd[1]: [email protected]: Control process exited, code=exited status=1
    Sep 21 00:09:46 octave systemd[1]: Failed to start Postfix Mail Transport Agent (instance -).
    Sep 21 00:09:46 octave systemd[1]: [email protected]: Unit entered failed state.
    Sep 21 00:09:46 octave systemd[1]: [email protected]: Failed with result 'exit-code'.

    Any ideas on how I can solve this problem?
     
  2. Nolan

    Nolan Member

    Anyone have any ideas?
     
  3. Nolan

    Nolan Member

    If anyone could help me solve this, that would be greatly appreciated.

    If you need additional logs or other information, please let me know.
     
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    did you add the ip to the master.cf from postfix and the bind-config?
     
  5. Nolan

    Nolan Member

    Yes. Note that NTP also trying to use these IPs and unable to do so. Typically NTP just binds to all available interfaces. It's like the bind is trying to happen before dibbler/dhclient is done doing what it needs to do.

    Edit: In /etc/postfix/main.cf:
    mynetworks = 127.0.0.0/8 [::1]/128
    smtp_bind_address = 212.129.7.140
    smtp_bind_address6 = [2001:bc8:3ca9:101::3]
    inet_interfaces = 212.129.7.140, 127.0.0.1, [2001:bc8:3ca9:101::3], [::1]

    I had this same Postfix configuration on my old server, and it worked fine at boot.
     
    Last edited: Sep 29, 2017
  6. Nolan

    Nolan Member

    Any other ideas? My host unfortunately is no help in this situation.
     

Share This Page