Services aren't reachable remotely

Discussion in 'Server Operation' started by bschultz, Jan 8, 2010.

  1. bschultz

    bschultz Member

    I'm having a problem with others being able to reach my server remotely...web, mail, ftp, ssh etc are all seeing the same problems.

    If I type in my domain name into my browser from work, I can't get to my website. I also can't connect to email or ftp. If I type in my IP address into the browser, I see the "It works" Apache page.

    I can connect with Putty to my server remotely...but I can't use WINSCP...it hangs on "reading remote directory".

    Others (on other IPS's) are also not able to connect to my websites. I am receiving emails...but I can't check my email remotely.

    I am running iptables and fail2ban (base install on both)...but don't see anything in the logs that is telling me that anything is wrong. In fact...this is the only error in the syslog:

    paulbunyan.net is my ISP...but I don't know who is on that IP address.

    Any ideas what might be going on here? I should add that I'm running Etch using a combination of Falko tutorials. The email portion is Mysql virtual users. The system has been running great for almost a year, and I haven't made any changes to anything recently.

    Thanks.

    Brian
     
    Last edited: Jan 8, 2010
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Does it work when you switch off the firewall and fail2ban (for testing purposes)?
     
  3. bschultz

    bschultz Member

    Thanks Falko...shutting off fail2ban and iptables made no difference.
     
  4. bschultz

    bschultz Member

    I'm at a remote location right now on wifi...I can't reach my server (on any service or program)...but a guy sitting right next to me (on the same wifi) can!

    This is getting confusing!
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is it maybe a problem with the firewall on your client PC?
     
  6. bschultz

    bschultz Member

    Multiple people on multiple networks are having the same problem reaching the server (Apache). I'm the only one that connects to SSH or FTP, so I don't know how widespread that problem is. I do know that I can't connect via SSH from my office.

    Could this be a DNS issue (DNS is done with GoDaddy), or some other routing (my router port forwards to my server) issue?
     
  7. bschultz

    bschultz Member

    Requests are coming into the server...here's a part of the Apache log when I tried to logon to my server from my work computer...

    It's been 10 minutes since I typed in the address for that domain...and still no page loaded in the browser. In fact, Firefox still says it's loading the page. I've run a speed test to see what my upload speed is...and it's at 5-8 megs per second...so that should be OK.

    The above line is the only sign of activitiy in the log...while most requests will show that several images and such have been requested.

    Thanks for the help!
     
  8. bschultz

    bschultz Member

    I'm also now seeing this

    in the mail logs while sending...and emails aren't being received...by some people, while others are being delivered.
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  10. bschultz

    bschultz Member

    And things are solved...my ISP replaced their router that served my location...and everything is once again reachable.

    Thanks, Falko!
     

Share This Page