Service suspended... but it isn't!

Discussion in 'ISPConfig 3 Priority Support' started by mlnzigzag, Mar 6, 2019.

  1. mlnzigzag

    mlnzigzag New Member HowtoForge Supporter

    On my ISPConfig master (Ubuntu 14, Apache) I had to delete a customer's website, say customerdomain.com, from the server and set the vhost as suspended on Feb 26. After setting such, the customer logged in and deleted his own vhost. Now, he asked me to recreate the vhost and restore the website, and I did.
    The local folder was changed from /var/www/clients/client31/web14 to /var/www/clients/client31/web117. The database did stay in its own place. It wasn't deleted nor disabled. So I just went into the database and associated the existing user and the new website again. The DNS is not handled by ISPConfig, thus is empty here, and is correctly configured at the ISP.

    Now, I'm still getting the "Service suspended" page.

    I can't get the clue on why, because:
    - checked vhost, and there isn't any .err, and the vhost for customerdomain.com points to the right folders
    - checked permissions and fixed to match the new user's web117
    - checked the website with a workstation that never viewed the site, outside of my network, to ensure there was no web/dns cache nor any other client related issue
    - any other website on the server is still working fine
    - I also tried to disable and re-enable this vhost with no luck
    - I also checked the customer's pane, nothing is disabled, the website is within the customer's limits.

    I guess investigations should go on reading the ispconfig database, but I don't know where to look.

    Any help would be highly appreciated. I'd perform and update the thread with any further checks you suggest.
     
    Last edited: Mar 6, 2019
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ispconfig has no service suspended page if I remember correctly, so how does the page actually look like? Maybe the cms or shop or whatever is hosted in that site is in a kind of suspended mode and shows this message? Or do you mean the apache default vhost page in /var/www/html/ ?

    There is no such thing in the database that you could check. Apache reads just ist config files and does not connect to the database and you verified already that the apache config is ok.

    Run the command:

    apachectl -S

    to see if the website config is actually included in ISPConfig and if the website uses ssl, ensure that the vhost file contains the ssl vhost part as well.
     
  3. mlnzigzag

    mlnzigzag New Member HowtoForge Supporter

    [​IMG]
    Code:
    [email protected]:/var/www# apachectl -S|grep customerdom
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:7
             port 80 namevhost customerdomain.com (/etc/apache2/sites-enabled/100-customerdomain.com.vhost:7)
    The service suspended page is included in ISPConfig. I've seen it as soon as I logged in ISPConfig and removed the "active" flag to the customer's vhost.

    Also, I've seen it before, when customer "forget to pay for their hosting" :)

    Please tell me what I could further check. Or how to redo the whole thing cleany to have the site back up.

    Also, this website has no SSL (...)
     
    Last edited: Mar 6, 2019
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, ok. Seems as we have a suspended page indeed :)

    Ok, so it's intended that it has no ssl?

    When you access that site with a browser, does the request show up in the access.log of that website? If yes, maybe this suspended page is a index.html page (file) in that site.

    And please post the output of:

    ls -la /etc/apache2/sites-enabled/100-customerdomain.com.vhost

    and the content of the file

    /etc/apache2/sites-available/customerdomain.com.vhost
     
  5. mlnzigzag

    mlnzigzag New Member HowtoForge Supporter

    The vhost was actually updated each time I reconfigured it if you meant to read this with ls -la and it was actually well configured.. but a missing piece.. :mad:
    The issue was the combination of missing autosubdomain: www. (see picture) and the fact that .htaccess had a redirect to customerdomain.com -> www.customerdomain.com (wich actually didn't exist in the new vhost configuration!)

    [​IMG]
    Glad if this will help anybody else! Thanks a lot @till for your always prompt help.

    Should I edit the topic as [SOLVED] or something?
     
    till likes this.

Share This Page