Servers stopped syncing

Discussion in 'Installation/Configuration' started by rsteuer, Jan 25, 2017.

  1. rsteuer

    rsteuer New Member

    We have 5 servers in a cluster (1-ISP Host, 2-DNS Severs, 1-Web Server, 1-DB Server - all running Jessie 8.6), that have stopped synchronizing. All servers were fully synchronizing as of 4 hours ago. I started adding and editing zone files earlier today with no problems. Later on, I started adding and editing more zones (we are migrating from older servers) and the synchronization never completed.

    I ran across https://www.howtoforge.com/community/threads/move-primary-dns-and-sql.74202/ and ran the server.sh script on all servers. All servers are throwing errors similar to:

    PHP Warning: mysqli_connect(): (28000/1045): Access denied for user 'ispcsrv5'@'FQDN'(using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 85
    Zugriff auf Datenbankserver fehlgeschlagen! / Database server not accessible!24.01.2017-20:14 - WARNING - Unable to connect to local server.
    PHP Warning: mysqli_ping() expects parameter 1 to be mysqli, null given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 198
    PHP Warning: mysqli_connect(): (28000/1045): Access denied for user 'ispcsrv5'@'FQDN'(using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 200

    I've checked the MySQL DBs on all servers and none have a MySQL user of ipcsrvx@FQDN. I attempted to create the user (found the username/password in /usr/local/ispconfig/server/lib/config.inc.php) but the errors are still there.

    How can I get past this issue? Why are the ispcsrvx users missing? As mentioned, this has been working flawlessly but changed in a matter of a couple of hours with no modifications other than the DNS edits. These servers are serving the DNS zones that are configured but we cannot add new zones or modify the existing zones.

    Your help is realty appreciated.
     
  2. rsteuer

    rsteuer New Member

    I stumbled upon another post (see Till's 2nd post in https://www.howtoforge.com/communit...einstalled-after-data-loss.71842/#post-337848) that lead me in the right direction. On all servers, I downloaded and extracted the ispconfig tar and ran the update per:

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php

    After running the update, the ispcsrvx users were added back to the master database but without passwords. I had to update the passwords in the master database by copying them from the /usr/local/ispconfig/server/lib/config.inc.php file on each server and specifying password type hash in phpmyadmin. This was done for all servers except the master. As soon as I updated the last user/password, syncing completed immediately.

    I am still concerned as to why the users were no, longer present. Not a very comforting feeling.
     

Share This Page