"ServerRoot" breaks Vhosts_ispconfig.conf

Discussion in 'Installation/Configuration' started by gentoose, Oct 9, 2006.

  1. gentoose

    gentoose New Member

    I've been fiddling around with Frontpage Extensions support on my Debian Testing box. Finally got it working, but I managed to destroy something else... Every time ISPConfig needs to update the vhosts, it starts the Vhosts_ispconfig.conf file with "ServerRoot". This is not accepted by Apache, so I just get a number of files in the apache vhost directory with Vhosts_ispconfig.conf-files, ending with date and time of file generation.

    Don't ask me what I did to cause this, but there must be a file to edit to make ISPConfig stop generate this line... Please?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use apache 1 or 2?
  3. gentoose

    gentoose New Member

    I'm using Apache2.
  4. gentoose

    gentoose New Member

    Nobody has any ideas?
  5. falko

    falko Super Moderator ISPConfig Developer

    Can you rename one of these Vhosts_ispconfig.conf-* files to Vhosts_ispconfig.conf and run
    httpd -t
    afterwards? What's the output? What's in the Vhosts_ispconfig.conf file?

    We tested FP only with Apache1, so I don't know if it works with Apache2.
  6. gentoose

    gentoose New Member

    Thank You for Your response Falko!

    It may be an ugly fix, but I think I solved the problem for now... The problem seemed to be that the debian testing package for apache2 is compiled with the HTTPD_ROOT directive empty, so a httpd -V just generated this:

    Server version: Apache/2.0.55
    Server built:   Aug  6 2006 00:17:59
    Server's Module Magic Number: 20020903:11
    Architecture:   64-bit
    Server compiled with....
     -D APACHE_MPM_DIR="server/mpm/prefork"
     -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
     -D HTTPD_ROOT=""
     -D SUEXEC_BIN="/usr/lib/apache2/suexec2"
     -D DEFAULT_PIDLOG="/var/run/apache2.pid"
     -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
     -D DEFAULT_LOCKFILE="/var/run/apache2/accept.lock"
     -D DEFAULT_ERRORLOG="logs/error_log"
     -D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
     -D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"
    I edited the file /root/ispconfig/scripts/lib/config.lib.php and changed the line
    $serverroot = "ServerRoot ".shell_exec("httpd -V | grep HTTPD_ROOT | cut -f2 -d'\"'");
    $serverroot = "ServerRoot         \"/etc/apache2\"";
    Now it's all good! But i still hate Frontpage Extensions... ;)
  7. gentoose

    gentoose New Member

    No, the ISPConfig support for FP does not appear to include apache2. I had to edit /root/ispconfig/scripts/lib/config.lib.php, and add "-t apache2.0" to every command concerning the owsadm.exe. A minor fix for a future release perhaps?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I've added it to the bug list.

Share This Page