Serverfail after Nameserver change

Discussion in 'Server Operation' started by micarl, Nov 4, 2009.

  1. micarl

    micarl New Member

    I would appreciate your help and direction as i'm new.

    Using both guides : fedora 10 server and godaddy Nameserver
    eveything seen to verify ok base on your guide. However I’m having a problem after changing nameserver, none of my domain can fine or make connection to my isp server.
    Doing the test :
    Dig example.com …. I get time out or serverfail
    Dig @ns1.nameserver .com any example.com … verified good
    Ns1. server and ns2 server work ok if I type in the browser…… but not my domain.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. micarl

    micarl New Member

    Ok I tried Intodns.com got a number of error.. I decided to start with godaddy because this is were my problem started. I simply change the ip address pointing to www for the domain in godaddy total dns, replace it with my ns1 ip, along with my new nameserver. It's working fine ...

    Dont know if this is the right way to result the issue but it work.

    Thanks a lot for your help.
     
  4. micarl

    micarl New Member

    Nameserver fail again

    I dont how to resolve this problem. I've little or no linux skills, None of my website can fine my nameserver. This is the result of two dig test.

    dig www.getpolicydirect.com
    [root@server1 ~]# dig www.getpolicydirect.com

    ; <<>> DiG 9.5.2-RedHat-9.5.2-1.fc10 <<>> www.getpolicydirect.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 24020
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.getpolicydirect.com. IN A

    ;; Query time: 1916 msec
    ;; SERVER: 68.87.74.162#53(68.87.74.162) **** internet provider Dns ***
    ;; WHEN: Sun Nov 8 13:06:20 2009
    ;; MSG SIZE rcvd: 41


    Doing Dig using my ip addr with domain: the result is better, I think.

    <<>> DiG 9.5.2-RedHat-9.5.2-1.fc10 <<>> @173.12.11X.XXX www.getpolicydirect.com
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12303
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;www.getpolicydirect.com. IN A

    ;; ANSWER SECTION:
    www.getpolicydirect.com. 86400 IN A 173.12.11X.XXX

    ;; AUTHORITY SECTION:
    getpolicydirect.com. 86400 IN NS ns2.bootra.com.
    getpolicydirect.com. 86400 IN NS ns1.bootra.com.

    ;; ADDITIONAL SECTION:
    ns2.bootra.com. 93738 IN A 173.12.11X.XXX

    ;; Query time: 1 msec
    ;; SERVER: 173.12.118.XXX#53(173.12.11X.XXX)
    ;; WHEN: Sun Nov 8 13:16:46 2009
    ;; MSG SIZE rcvd: 116
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I've tried, and it seems as if ns1.bootra.com and ns2.bootra.com aren't responding. Is BIND running on both?
    Does the firewall allow port 53 (TCP and UDP)?
     
  6. micarl

    micarl New Member

    Thanks a lot , port 53 needed to be enabled on my comcast router/firewall. Now it is working. I greatly appreciate your help, i've been trying for 3 weeks to resolve this
    problem.
     
    Last edited: Nov 9, 2009

Share This Page