Server working but now stuck - How do I link a domain name

Discussion in 'Installation/Configuration' started by AndrewCow, Nov 30, 2010.

  1. falko

    falko Super Moderator ISPConfig Developer

    I need the output of
    Code:
    netstat -tap
    BTW, if you use an SSH client such as PuTTY, you can copy&paste the output.
     
  2. AndrewCow

    AndrewCow New Member

    Code:
    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      1516/master
    tcp        0      0 *:mysql                 *:*                     LISTEN      826/mysqld
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      979/spamd.pid
    ^C
    [email protected]:~#
    Thank you so much. I'm sorry about my noobishness:)
    AndrewCow
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Apache isn't running (which explains why you cannot reach ISPConfig). Also, amavisd isn't running, and Postfix is listening only on port 10025, but not on 25. Please start Apache and amavisd and restart Postfix.
     
  4. AndrewCow

    AndrewCow New Member

    How do I start them :( ? I thought I knew but I don't. Sorry I am a mega terminal noob. I reinstalled apache and now it looks like this.
    Code:
    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      1537/master
    tcp        0      0 *:mysql                 *:*                     LISTEN      833/mysqld
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      991/spamd.pid
    tcp        0      0 192.168.0.113:domain    *:*                     LISTEN      851/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      851/named
    tcp        0      0 *:ssh                   *:*                     LISTEN      725/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      1537/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      851/named
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      987/amavisd (master
    tcp        0      0 localhost.localdo:42991 localhost.localdo:mysql ESTABLISHED 992/amavisd (ch1-av
    tcp        0     52 192.168.0.113:ssh       192.168.0.109:49426     ESTABLISHED 1688/0
    tcp        0      0 localhost.localdo:42994 localhost.localdo:mysql TIME_WAIT   -
    tcp        0      0 localhost.localdo:10025 localhost.localdo:48809 ESTABLISHED 1837/smtpd
    tcp        0      0 localhost.localdo:42989 localhost.localdo:mysql TIME_WAIT   -
    tcp        0      0 localhost.localdo:48809 localhost.localdo:10025 ESTABLISHED 992/amavisd (ch1-av
    tcp        0      0 localhost.localdo:42993 localhost.localdo:mysql TIME_WAIT   -
    tcp        0      0 localhost.localdo:mysql localhost.localdo:42991 ESTABLISHED 833/mysqld
    tcp        0      0 localhost.localdo:42995 localhost.localdo:mysql TIME_WAIT   -
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      1429/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      1395/couriertcpd
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      851/named
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      725/sshd
    tcp6       0      0 localhost:953           [::]:*                  LISTEN      851/named
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      1415/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      1449/couriertcpd
    [email protected]:~#
    
    Is it any better. After I reinstalled it, it worked for a bit but once again could not see any servers that after a restart stopped again:(
    Thanks
    AndrewCow
     
    Last edited: Dec 14, 2010
  5. falko

    falko Super Moderator ISPConfig Developer

    Code:
    /etc/init.d/postfix restart
    /etc/init.d/amavisd restart
    /etc/init.d/apache2 restart (Debian/Ubuntu)
    /etc/init.d/httpd/restart (Fedora/CentOS)
     
  6. AndrewCow

    AndrewCow New Member

    lol...im an idiot... thankyou
     
  7. AndrewCow

    AndrewCow New Member

    By the way thank you so much for all your help:)
     

Share This Page