Server working but now stuck - How do I link a domain name

Discussion in 'Installation/Configuration' started by AndrewCow, Nov 30, 2010.

  1. AndrewCow

    AndrewCow New Member

    Hi
    So I have a domain name on Go Daddy and a fresh working ISPConfig 3 server. How do I link www.example.com to my server with a hostname exampleserver.example.com?

    I know this is a bit of a noob question and I am missing something big but I have been searching for days and can't find anything?

    Please help
    AndrewCow
     
  2. AndrewCow

    AndrewCow New Member

    Also I have bought the manual and looked through it. I cant find anything. It must be simple. Everyone else seems to be able to do it.
     
  3. cbj4074

    cbj4074 Member HowtoForge Supporter

    Just to clarify, you have a domain name registered with GoDaddy, and you want to create a subdomain that lives on the server with ISPConfig?

    What are you using for nameservers for the top-level domain? GoDaddy's nameservers? Or have you put your hosting provider's nameservers there in-place of GoDaddy's?

    Do you already have a server to which your top-level domain resolves? If so, do you require that server to remain online, completely apart from the ISPConfig server to which the subdomain should point?
     
  4. AndrewCow

    AndrewCow New Member

    Ok. Hopefully this will answer it. I would like to use the go daddy name servers to connect my URL to my server. I would like to use my server as an email client as well as hosting web pages. The only reason I want to use the Go daddy name servers it because I thought if I used my own, I would need to have two servers, which I don't at this time.
    Thanks
    AndrewCow
     
  5. falko

    falko Super Moderator ISPConfig Developer

    You can manage your DNS records through the GoDaddy web interface. Let's say you want to host the web site example.com/www.example.com and want to receive mails for example.com.

    Then you need A records for example.com, www.example.com, and mail.example.com that point to the public IP of your server. Firthermore you need an MX record for example.com that points to mail.example.com.
     
  6. AndrewCow

    AndrewCow New Member

    thanks. Ill try that:):)
     
  7. AndrewCow

    AndrewCow New Member

    So do I just use the public ip address that is the same for all my computers or do I have to so something to direct it to that specific server. Sorry I am a major networking n00b:(
     
  8. cbj4074

    cbj4074 Member HowtoForge Supporter

    The fact that your domain(s) are hosted with GoDaddy is fine; that's not an issue.

    We need to know where the server on which ISPConfig is installed resides. Is this a "home PC" that's in a home or business? Or do you have a hosted account somewhere (e.g., with mediaTemple, BlueHost, RackSpace, or one of the million other hosts out there)?

    The answer to that question will help us put you on the correct track.

    Basically, you have two options:

    1.) Use GoDaddy's nameservers (see http://help.godaddy.com/article/664 )

    2.) Use your Web hosting company's nameservers

    If you're hosting the server on which ISPConfig is installed at home, then you must use option #1, because option #2 does not apply.

    If the server is hosted professionally, then your Web host (not to be confused with GoDaddy, who is your domain host) will have a "control panel" of sorts for creating DNS records for the domain.

    Once we know whether it's #1 or #2, we can do more to help...
     
  9. AndrewCow

    AndrewCow New Member

    thanks:) its option 1:) I don't have a hosting provider. Its just the go daddy domain and my server:)
    Thanks
     
  10. AndrewCow

    AndrewCow New Member

    OOO ok so I have partially solved my problem. Now my site name redirects to the settings page of my router. How do I get it to go to my server??
     
  11. falko

    falko Super Moderator ISPConfig Developer

    You must configure your router to forward port 80 to your ISPConfig server.
     
  12. cbj4074

    cbj4074 Member HowtoForge Supporter

    I will add to Falko's reply that if you intend to access the ISPConfig interface from anywhere outside your home, you will also need to forward port 8080 to your server's LAN IP address.

    If you intend to use SSL with Apache, port 443 must be forwarded, too.

    If you need help with port-forwarding, see http://portforward.com .
     
  13. AndrewCow

    AndrewCow New Member

    Thank you soo much:):) I'll try that. You guys are awesome
     
  14. AndrewCow

    AndrewCow New Member

    Ok so now I have even more problems. Firstly, I am pretty sure I have set up the port forwarding but it still goes to the router page. My server, which was working fine, now does not seem to be. I cant access the ISPConfig pannel or squirrel mail but when I boot the server, it doesn't appear to have any problems. I also am not sure if I did the port forwarding properly. On my dlink router, i think it is called virtual server. DO you know if there are the same things. Thank you so much for all your help.
    AndrewCow
     
  15. AndrewCow

    AndrewCow New Member

    Its working!!!!! Thank you so much for all your help!!
     
  16. AndrewCow

    AndrewCow New Member

    Wait. No it does not. OK i will try and be consise:) If you would like me to open a new ticket tell me. OK. So I have the domain linked and the ports forwarded but now the ISPConfig server does not display its self. This happened before and I managed to rendomly get it working but under that circumstance, no servers were available on any of the menus. What should I do? Thank you so much for your help.
    AndrewCow
     
  17. falko

    falko Super Moderator ISPConfig Developer

    To use the ISPConfig control panel, you must forward port 8080.
     
  18. AndrewCow

    AndrewCow New Member

    Yes I have. It also does not work if I use its local IP address which would not need the port forwarding.
     
  19. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ?
     
  20. AndrewCow

    AndrewCow New Member

Share This Page