Server Timeout / Additional Ip Addres

Discussion in 'ISPConfig 3 Priority Support' started by backofficegeorgia, Oct 16, 2018.

  1. backofficegeorgia

    backofficegeorgia New Member

    I am using bellow setup and have 2 issues.
    Additions: Rami PHP7.1

    1. I have configured max_execution_time to 0 in php.ini and i also use ini_set('max_execution_time', 0); set_time_limit(0); strings in my php script file. i am executing script using ISPconfig cron. i am getting 503 error in browser and also bellow is error of cron from server logs:
    I need to remove all limits for my single php file or in case if mandatory for whole domain name.

    1. I have new ip address, which was added in system->server ip address, also i have changed ip address of my domain from Site-Websites-Mysite-IPv4-Address and also changed DNS settings of domain to new ip address. i am not able to access my website any more using domain name, it is directed to default server site on first ip address. when i type second ip address in browser all is working fine. (kindly note that i have multiple domains and new ip should be assigned to specific website only)
    Last edited: Oct 16, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The timeout that you experience is not a php timeout as far as I can see, its a timeout of the web server. I guess you are using a web cron at the moment, does your script support it that you call it as php shell script too? In that case, better run it via cron as PHP shell script.

    Then your dns change has not been propagated yet. Did you wait 24 hours after you changed DNS?
  3. backofficegeorgia

    backofficegeorgia New Member

    I think it is not supported to execute the script using shell, i have lots of error. is there any way to bypass the restriction of web server for specific domain ?

    Reference to second issue you are correct, i use cloudflare and all dns records are getting updated in second, seems that ip change takes more time. now i cheeked and all works fine.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to add this in the apache directives field of the website:

    TimeOut 120
    ProxyTimeout 120

    the numbers are the timeout in seconds, set them to the time you need.
  5. backofficegeorgia

    backofficegeorgia New Member

    i have added bellow lines from Ispconfig Sites->Websites->mysite->Options
    TimeOut 0
    ProxyTimeout 0
    still i receive the same error

Share This Page