Server stopped completely after new website creation

Discussion in 'Installation/Configuration' started by pawan, Nov 15, 2011.

  1. pawan

    pawan Member HowtoForge Supporter

    After Upgrading to 3.0.4 I was adding the first website today.
    I have added the client and then domain alright.

    When I was adding website for the domain, the control panel freezed, on refresh,
    The control panel was gone, none of the website are opening.

    I tried to restart apache and I am getting this error.

     * Restarting web server apache2                                                [Tue Nov 15 21:31:51 2011] [warn] The Alias directive in /etc/apache2/conf.d/webmail.conf at line 5 will probably never match because it overlaps an earlier Alias.
    Syntax error on line 62 of /etc/apache2/sites-enabled/
    FcgidMaxProcesses cannot occur within <VirtualHost> section
                                                                             [fail] is the site I was adding.

    and line62 is - FcgidMaxProcesses 1000

    I have deleted the whole block and everything was back-again.

    The question is how I should handle this?
    I mean - <IfModule mod_fcgid.c>
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the file /usr/local/ispconfig/server/conf/vhost.conf.master and comment out that line there. Or install the ISPConfig RC1 where this line is commented out already.
  3. tuxfan

    tuxfan New Member

    I got the same error after installing pecl and uploadprogress on Debian 6

    The real bug is for some reason messing up the fastcgi syntax. On apache 2.2 you need the 2.2 setting on fastcgi_config_syntax.

    Just comenting it out just results in fastcgi php stops working.

    The line mentioned should never be included - the

    tmpl_if name='fastcgi_config_syntax' op='==' value='2'

    on line 176 in vhost.conf.master

    should make the script skipp those lines.

    It seems like the fastcgi_config_syntax gets messed up somewhere on the way.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Off course, I did not tell you to select anything else. You shall only comment out the line that starts with:


    in the file /usr/local/ispconfig/server/conf/vhost.conf.master as this setting should not be in that place in a vhost. Tested that in 3.0.4 and and it works as it should, nothing is messed up.

    So to fix your problem, either comment out that line or update to as I suggested.
  5. tuxfan

    tuxfan New Member

    Right Till - I did comment that line out (and none else) - but it didnt help.

    (Or to be exact - the webserver did start - but php fast-cgi didnt work).

    It might work on Apache 2.0 syntax - but not on 2.2
    (and yes I did select the 2.2 syntax - since you othervise will get "No input file specified." - now I get it anyway)

    I think its quite strange that that line maters -
    since the tmpl_if should skip those lines and use those from line 186.
    Last edited: Nov 17, 2011
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Tested that on my Debian server and fastcgi works there. The line FcgidMaxProcesses is not relevant for fastcgi, its just a optional config parameter. You might want to upgrade your server to RC1.
  7. tuxfan

    tuxfan New Member

    Do your server have pecl and any extensions installed?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    My server is installed as described in the perfect setup guide. The perfect setup guides describe the system requirements for ISPConfig.
  9. tuxfan

    tuxfan New Member

    Found the problem - the new version sets SuExec as default. Had just to disable that.

Share This Page