restarting apache in loop

Discussion in 'General' started by maxxer, Aug 1, 2014.

  1. maxxer

    maxxer Member

    I had some troubles today with PHP and apache configuration, after I managed to fix it up I realized the script was stuck in a loop restarting apache.
    Now I cannot figure out what's going wrong with that. If I manually run I get no output at all. sys_log table doesn't say nothing, no messages in /var/log/ispconfig. I can just see the restarts in /var/log/apache2/error.log.

    Luckily services are running, but I cannot change anything in config.
    Where can I check what's wrong?
    I'm running the latest on Ubuntu12.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. maxxer

    maxxer Member

    thanks for your support.
    just before your message I enabled debug and saw the server update script has 1000+ operations left, and it seems to be restarting the apache server on EVERY config write.
    My server has ~250 domains configured, is it normal to have so many operations left?

    Maybe it's better if I clean the queue and do a resync? Is it safe to do? In case, how can I clean the operations queue?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you used the resync tool in ispconfig several times on the domains or you used resnc on all items. When you run resync, then the selcted items get reconfigured as if you changed something manually and click save. When the apache config check is enabled then under System > server config web, then apache gets restarted after each website to check if this website change will cause any problems in apache.
  5. maxxer

    maxxer Member

    indeed that was the problem, disabling apache check fastened up the process. I've some more issues, if you have some time to have a look:

    1. I didn't find the option to disable php5-fpm restart during resync;
    2. isn't it faster to do a "apache2ctl configtest" instead of restarting the whole apache? The same goes for php5-fpm, there's a useful option -t;
    3. during the sync php5-fpm was stopped and has never been restarted by ISPConfig, I had to start it manually!


Share This Page