Server Settings disappears in ISPConfig!

Discussion in 'General' started by Quaxth, Jan 14, 2014.

  1. Quaxth

    Quaxth New Member

    As the title says: there no any settings in Server System:

    [​IMG]

    Nothing is shown in Server Services and Server Config, everything is empty!

    [​IMG]

    That was happen after I added 3 new ports to the Firewall. What to do to get settings back?

    By the way, Mail Server is working as well as Webmail.

    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You must have deleted the servr record instaed of the firewall record, as thats the only way that the server settings may disappear. As you deleted the record, you will have to restotre it e.g. from a backup of your server.

    If you dont have a backup of your server, then you can try to build yourself a new server record by using the ispconfig mysql dump in the install tar.gz file and then insert the content of the server.ini file into the conf field of your new server record. as last step, you will have to adjust the settings in the server config to match your installation.
     
  3. Quaxth

    Quaxth New Member

    Sorry Till, I deleted nothing, just added 3 ports to the firewall!

    Could you please guide me with the set of a new Server Record? Also, I'm not sure about the backup, I had some some but couldn't find! Where to look for the file for to restore? And If I found, what the command?

    Thanks a lot for your help.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you dont remember that you clicked on the red [-] delete icon in the server services list and confirmed the deletion. Technically ist impossible that the server settings, which are not related to the firewall at all (neither in the frontend code nor the database), get deleted when you add a port (at least if you havent altered any code in ispconfig).

    If you find your backup, then restore the content of the dbispconfig database into a empty new database with phpmyadmin. Then use phpmyadmin to export the record which is in the server table from yur backup database and import it into the server table of the active dbispconfig database.
     
  5. Quaxth

    Quaxth New Member

    Again: I do not deleted anything! Believe me or not, the only changes I had done were open ISPConfig, gone to the firewall and added 8019, 8094 an 8443 as new ports. NOTHING were deleted from my site!

    [​IMG]

    When I clicked on Monitor for to see there any messages, I was just getting a blank screen!! than gone back to Server and there also everything were empty. Checked Mail, all OK and same for Sites.

    By no any means I clicked on any Delete button!!

    I was looking for the Backup but find.

    So please give me an guide how to create a new Server Record from cratch

    Thanks a lot.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use and do you use apache or nginx and do you use dovecot or courier?
     
  7. Quaxth

    Quaxth New Member

    It's a Debian Wheezy 7.1 Server with Apache and Dovecot, ISPConfig 3.0.53 of course!

    At the same time I may could update Debian to 7.3 which is released already.

    Thanks for your help and please post the detailed commands I need to use.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Execute the following sql query with phpmyadmin in the dbispconfig mysql database:

    Code:
    INSERT INTO `server` (`server_id`, `sys_userid`, `sys_groupid`, `sys_perm_user`, `sys_perm_group`, `sys_perm_other`, `server_name`, `mail_server`, `web_server`, `dns_server`, `file_server`, `db_server`, `vserver_server`, `proxy_server`, `firewall_server`, `config`, `updated`, `mirror_server_id`, `dbversion`, `active`) VALUES
    (1, 1, 1, 'riud', 'riud', 'r', 'server1.example.com', 1, 1, 1, 1, 1, 1, 0, 0, '[global]\nwebserver=apache\nmailserver=postfix\ndnsserver=mydns\n\n[server]\nauto_network_configuration=n\nip_address=192.168.0.100\nnetmask=255.255.255.0\ngateway=192.168.0.1\nhostname=server1.example.com\nnameservers=192.168.0.1,192.168.0.2\nfirewall=bastille\nloglevel=0\nadmin_notify_events=1\nbackup_dir=/var/backup\nbackup_mode=rootgz\nmonit_url=\nmonit_user=\nmonit_password=\nmunin_url=\nmunin_user=\nmunin_password=\n\n[mail]\nmodule=postfix_mysql\nmaildir_path=/var/vmail/[domain]/[localpart]\nhomedir_path=/var/vmail\npop3_imap_daemon=dovecot\nmail_filter_syntax=sieve\nmailuser_uid=5000\nmailuser_gid=5000\nmailuser_name=vmail\nmailuser_group=vmail\nrelayhost=\nrelayhost_user=\nrelayhost_password=\nmailbox_size_limit=0\nmessage_size_limit=0\nmailbox_quota_stats=y\nrealtime_blackhole_list=\noverquota_notify_admin=y\noverquota_notify_client=y\noverquota_notify_freq=7\noverquota_notify_onok=n\n\n[getmail]\ngetmail_config_dir=/etc/getmail\n\n[web]\nserver_type=apache\nwebsite_basedir=/var/www\nwebsite_path=/var/www/clients/client[client_id]/web[website_id]\nwebsite_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/\nwebsite_symlinks_rel=n\nvhost_conf_dir=/etc/apache2/sites-available\nvhost_conf_enabled_dir=/etc/apache2/sites-enabled\nnginx_vhost_conf_dir=/etc/nginx/sites-available\nnginx_vhost_conf_enabled_dir=/etc/nginx/sites-enabled\nsecurity_level=20\nuser=www-data\ngroup=www-data\nnginx_user=www-data\nnginx_group=www-data\napps_vhost_port=8081\napps_vhost_ip=_default_\napps_vhost_servername=\nphp_open_basedir=[website_path]/web:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin\nhtaccess_allow_override=All\nawstats_conf_dir=/etc/awstats\nawstats_data_dir=/var/lib/awstats\nawstats_pl=/usr/lib/cgi-bin/awstats.pl\nawstats_buildstaticpages_pl=/usr/share/awstats/tools/awstats_buildstaticpages.pl\nphp_ini_path_apache=/etc/php5/apache2/php.ini\nphp_ini_path_cgi=/etc/php5/cgi/php.ini\ncheck_apache_config=y\nenable_sni=y\nenable_ip_wildcard=y\novertraffic_notify_admin=y\novertraffic_notify_client=y\nnginx_cgi_socket=/var/run/fcgiwrap.socket\nphp_fpm_init_script=php5-fpm\nphp_fpm_ini_path=/etc/php5/fpm/php.ini\nphp_fpm_pool_dir=/etc/php5/fpm/pool.d\nphp_fpm_start_port=9010\nphp_fpm_socket_dir=/var/lib/php5-fpm\nset_folder_permissions_on_update=y\nadd_web_users_to_sshusers_group=y\nconnect_userid_to_webid=n\nconnect_userid_to_webid_start=10000\nweb_folder_protection=y\noverquota_notify_admin=y\noverquota_notify_client=y\noverquota_notify_freq=7\noverquota_notify_onok=n\nwebsite_autoalias=[client_username]-[website_id].domain.tld\nCA_path=\nCA_pass=\n\n[dns]\nbind_user=root\nbind_group=bind\nbind_zonefiles_dir=/etc/bind\nnamed_conf_path=/etc/bind/named.conf\nnamed_conf_local_path=/etc/bind/named.conf.local\n\n[fastcgi]\nfastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/\nfastcgi_starter_script=.php-fcgi-starter\nfastcgi_alias=/php/\nfastcgi_phpini_path=/etc/php5/cgi/\nfastcgi_children=8\nfastcgi_max_requests=5000\nfastcgi_bin=/usr/bin/php-cgi\nfastcgi_config_syntax=1\n\n[jailkit]\njailkit_chroot_home=/home/[username]\njailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh\njailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /usr/bin/lesspipe /usr/bin/basename /usr/bin/dirname /usr/bin/nano /usr/bin/pico\njailkit_chroot_cron_programs=/usr/bin/php /usr/bin/perl /usr/share/perl /usr/share/php\n\n[vlogger]\nconfig_dir=/etc\n\n[cron]\ninit_script=cron\ncrontab_dir=/etc/cron.d\nwget=/usr/bin/wget\n\n[rescue]\ntry_rescue=n\ndo_not_try_rescue_httpd=n\ndo_not_try_rescue_mysql=n\ndo_not_try_rescue_mail=n\n\n', 283, 0, 60, 1);
    
     
  9. Quaxth

    Quaxth New Member

    WOW!! That looks terrible for me!!

    Question: the Server settings like IP, Netmask, Gateway, Server name (host.excample.com) etc. etc, which I may know, do I need to change them to the real one or should I use the Query script as you posted?

    I really get lost here!

    Thanks.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Just run the script like I posted it. You can adjust values afterwards in ispconfig, where nescessary.
     
  11. Quaxth

    Quaxth New Member

    So. in PHPMyAdmin I open the database, copy and paste the script in Query and run? Is that right?:

    Thanks.
     
  12. Quaxth

    Quaxth New Member

    Also, just for future work and security, what would be the best apps for to backup the server? What's about Acronis True Image? or other apps?

    Thanks.
     
  13. Quaxth

    Quaxth New Member

    As I try to run that script, what do I do with the empty columns? I was run once and get:

    [​IMG]

    Thanks, and I've to admit that I'm quite helpless at this point!
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Go to the sql tab, not query tab in phpmyadmin
     
  15. Quaxth

    Quaxth New Member

    Done that and now: I con't login to ISCOnfig anymore!

    Also Webmail didn't works now!

    What's going wrong?

    Thanks.
     
  16. Quaxth

    Quaxth New Member

    OK, now NOTHING is working anymore. I could not connect to the server neither by PuTTY or by WinSCP! ISPConfig could not be opened again and same is happen now for PHPMyAdmin! Localhost didn't works anymore.

    What I should do now??????
     
  17. Quaxth

    Quaxth New Member

    It seems to be that the settings, special for Network and Server etc. should had been the actual settings and not the one you used in your script.
    All of them, started with the NIC setting, DNS and Hostname etc. are totally wrong.

    That was why I asked you upfront I should change them to the actual know settings. Now it seems to be that I've to re-install the whole server from ground zero!

    Good thing now is, that I used the Nameserver of my Registra and only normal A Records and not the DNS Zone feature in ISPConfig. I set all Mail nor forwarded to my gmail account on my Registra Account, so I don't lose important mails.

    The bad thing is that I lose the control of the Server via PuTTY and WinSCP! I could only use the the Server Terminal on Server Monitor, which is terrible!

    Even I was try to get PuTTY back to work, it's impossible. The Network Sewttings are still on default and correct setting, the script hasn't changed that. Maybe the problem is that the script changed the settings inside ISPConfig and that has an effect on the whole server.

    Any Idea how to solve that? Thanks.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    This does not matter as network configuration is disabled in these settings, so they dont get used at all. So there could be only a problem if you enabled network settings before you changed the data.

    In any case, no need for a reinstall.

    Check the network configuration in /etc/network/interfaces
     
  19. Quaxth

    Quaxth New Member

    Sorry Till,I didn't done anything else than just followed your advice word by word, even asked for confirmation upfront not to doing anything wrong! Fact as of now is that the server couldn't work and is totally un-accessible even via the local LAN!

    That was the first thing I'd done on Server terminal directly on the server itself, not remotely! All those settings are correct! The Internet is accessible from the server directly, that woks just well! No way for to get connect via LAN using any solution like PuTTY, WinSCP, FTP or http/https! Also no way to connect from the Internet to the server, I also checked that using 3G via an different ISP!

    For me that looks like that I've no other way as doing an re-installation from Ground Zero! Therefore I'd set all Mail accounts via the forwarding feature from my Registra to be forwarded to my gmail account for the time being till the server is back online and running correctly. I downloaded the latest version of Debian Whezzy 7.3 already and will in the morning starting with the re-installation. Most will work within an short period of time, maybe 2-3 hour's! And as I see that, that will be much faster than to try to get the server back to work, if that would possible, which I doubt!

    Thank you for your help even it didn't helped.
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Still no need for a reinstall, be a bit mor patient. your server is fine, its just not acessible.

    Ok, so the network configuration is ok. So the issue is most likely related to yourfirewall changes and not the import of the server settings. The firewall changes just had not been applied yet due to the missing server record.

    run:

    iptables --flush

    on the shell and try to connect to your server again, this will remove all firewall rules.

    and check that you have a correct nameserver listed in /etc/resolv.conf
     

Share This Page