Server refused our key (OpenSSH/Putty)

Discussion in 'Installation/Configuration' started by shelzmike, Feb 2, 2012.

  1. shelzmike

    shelzmike New Member


    New to Ubuntu Server (and rusty on Linux in general). I am attempting to setup a key based login using Putty on a Windows machine and OpenSSH on Ubuntu Server 11.10.

    Followed this awesome tutorial here (

    Every time I keep getting server refused our key.

    I have tried it twice and think maybe I am missing something.

    Do I need to change the authorized key files on OpenSSH config file? (Because I tried it without doing that, then I changed it to ~/.ssh/authorized_keys2)

    Any help. I am sure it is something simple.

    Thanks! Mike
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you put the correct key into ~/.ssh/authorized_keys2? Did you put it in the authorized_keys2 file of the user that you want to log in as?
  3. shelzmike

    shelzmike New Member

    Yes, I had completed those steps; however, that did not fix the issue. But, I was able to finally resolve the problem using this help:

    Apparently, the home directory in Ubuntu Server 11.10 is encrypted until you log in, which obviously does not work. I just moved the authorized_keys file to another non-encrypted location and it worked like a charm. Thanks for the reply!


Share This Page