server.php - multiple instances (100's!!!)

Discussion in 'General' started by Mitro, May 30, 2009.

  1. Mitro

    Mitro New Member

    there is a problem with my ISPConfig3 installation:
    The script "/usr/local/ispconfig/server/server.php" is started every time and still running indefinitely. After a some hours of server running I seen 100's of instances of this script in "top".

    As I can see, this script "stops" or "indefinitely waits" on "$app->modules->processDatalog();" string and nothing happened next.

    Now I just truncate this script to "die();" because it fills all the memory with it's instances.

    What can be wrong?
    System: Debian Lenny
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a good idea as we can not debug it like this. Remove the die command and comment it out in the root crontab instead.

    Please enable debugging in the file /usr/local/ispconfig/server/lib/config,inc.php by setting the $conf["log_priority"] to 0 and then post the debug output that you get when you run:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock
  3. Mitro

    Mitro New Member

    Thank you for your advice.
    Here is the output:
    "Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'."

    and its stops after this line.
    Last edited: Jun 1, 2009
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And no other error messages on the shell?
  5. Mitro

    Mitro New Member

    02.06.2009-12:58 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    02.06.2009-12:58 - DEBUG - Found 55 changes, starting update process.
    02.06.2009-12:58 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.

    I waiting 10-12 minutes before terminate the script.
    Last edited: Jun 2, 2009
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Did you make any changes to the mail plugin or mail module?
    If an error occures (php parsing error) in one of those files the server script aborts without message.
  7. Mitro

    Mitro New Member

    No, nothing was changed in other scripts.
    And script didn't aborts, it stops without exit and staying in memory.
  8. bongo

    bongo New Member


    today i had the same problems with
    More and more instances of the load up, so i am forced to deativate it in crontab.

    I had no problems before, i just compiled Postfix 2.6.2 from the source,
    this went well and postfix is working good.

    But since the install i have these problems with multiple instances.

    There is a solution?

    Thank you,
  9. bongo

    bongo New Member

    Additional note: I removed sendmail with yum, this could be the problem?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to update to the latest svn version or use the mail plugin from svn, there had been several fixes in the mail plugin. also make sure that all files in the /var/vmail folder belong to user and group vmail or maildirmake can fail.

Share This Page