server name settings

Discussion in 'Installation/Configuration' started by gwa7, Jan 10, 2007.

  1. gwa7

    gwa7 New Member

    I have two domains running on ispconfig: :

    The DNS is hosted by my ISP.

    When I do a dns report on I get this message: claims to be host [but that host is at (may be cached), not].

    My question is this: how do I get the server to respond as for and for

    All the postfix messages from the server say even for

    I would like for those messages to say for the domain. I don't wan't anyone on the domain to see in their emails. Is this possible?

    I appreciate any help on this.
    Last edited: Jan 10, 2007
  2. mphayesuk

    mphayesuk Member

    Could be going off point here but what did you call your ispconfig server?

    I have used the same tools as you used on two of my domains, and and the records were all ok.

    So when you created the site in ispc you specifed your mail server to be internal?
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    This is called sender based routing. Postfix can do this, but it's not very easy to setup and I don't know if it breaks ISPConfig. Google for "postfix sender based routing". The trick appears to be to setup a second Postfix instance that will be used for sending email. The original postfix instance remains for receiving email.
  4. gwa7

    gwa7 New Member

    Thank you very much for your quick reply.
    Regarding the name of the ispconfig server: the host name of the computer is However I have an additional ip address for with an alias name of clgsite. This is just the normal network configuration outside of ispconfig. Is there a place within ispconfig to set the server name? If yes, please let me know where.
    Regarding the mail server to be internal: I just checked and it was set to external. I just put it on internal. I am not sure why it was set to external. However, nothing seems to have changed.
    Thanks again for your help and I look forward to your reply.
  5. gwa7

    gwa7 New Member

    Thank your very much for your quick reply. I will search google like you suggested.
    Would you know of a quick way to take the mail server name out of the bounce messages so the end user does not see the mail server name? I have found info on changing the bounce template, but I don't have a bounce template.
    Thanks again,
  6. gwa7

    gwa7 New Member

    Another question report this about

    WARNING: One or more of your mailservers is claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). If your mailserver sends out E-mail using this domain in its EHLO or HELO, your E-mail might get blocked by anti-spam software. This is also a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server. Note that this one test may use a cached DNS record. claims to be host [but that host is at (may be cached), not].

    How do I get to claim it is instead of
  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Hmm, what are you bouncing? Bouncing SPAM is considered 'backscatter' nowadays and will put your server quickly on spam RBL's. It's better to accept mails and use the procmail recipies to store them immediately in a 'SPAM suspect ' mailfolder.

    You could try to isolate a recognizable piece of the bounce message and issue something like
    grep -ir "string to search" /home/admispconfig/*
  8. gwa7

    gwa7 New Member

    I apologize, I don't think I made the bouncing question very clear. I don't think I am bouncing spam. I setup spam just to be discarded in ISPconfig. I think we are getting denied because of the name issue described above. Here is the message that email users are getting back when trying to send to certain email recipients:

    From: Mail Delivery System [mailto:[email protected]]

    Sent: Wednesday, January 10, 2007 9:08 AM
    To: [email protected]
    Subject: Undelivered Mail Returned to Sender

    This is the Postfix program at host

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]>: host[]
    said: 550 5.7.1 Relaying denied. IP name lookup failed []
    see for more details
    reply to MAIL FROM command)
  9. falko

    falko Super Moderator ISPConfig Developer

    The problem here is that has no PTR record:
    dig -x
    ; <<>> DiG 9.3.2-P1 <<>> -x
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 47897
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;      IN      PTR
    ;; AUTHORITY SECTION:  3600    IN      SOA 2002062400 86400 1800 604800 3600
    ;; Query time: 161 msec
    ;; SERVER:
    ;; WHEN: Thu Jan 11 20:09:15 2007
    ;; MSG SIZE  rcvd: 100
    Please ask the ISP that gave you that IP address to create one.

    Regarding the problem: I think the easiest solution would be to make point to instead of As it is still the same server it should work.
  10. gwa7

    gwa7 New Member

    Thank you for your reply. I will try that and let you know. However, I have a question. I have four ip addresses on the machine - 73.
    I have PTR records on and ISPconfig runs on I don't understand why the ip address even comes into the picture.
    Thanks again,
  11. gwa7

    gwa7 New Member

    Based on your suggestions I got it working. Here is what I did. I created a new domain name and pointed that to The server name is I then changed the mxrecords of the other domains to be This made everything work and all the emails are going through now.
    Thanks to everyone for your help! This forum has been a great resource.
    Now I just have one more thing to work out with the certificates, but I will start another post on that one.
    Thanks again,

Share This Page