Server Name - DIG

Discussion in 'Installation/Configuration' started by stef157, Sep 16, 2013.

  1. stef157

    stef157 Member

    Server Name - DIG [Resolve]

    Hi all,
    I just get an DOT.TK domain for testing my server before the transfer…

    And the problem is that, when I dig NS domain.tk, I get this answer :

    Code:
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 12820
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; AUTHORITY SECTION:
    .			600	IN	SOA	x. hostmaster.foo.com. 2000042100 600 600 1200 600
    
    ;; Query time: 52 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Mon Sep 16 10:30:42 CEST 2013
    ;; MSG SIZE  rcvd: 86
    
    Do you have an idea what's wrong with my config ?

    Thanks for reading.
     
    Last edited: Sep 17, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact dig command did you use and which errors do you got in the syslog file from named?
     
  3. stef157

    stef157 Member

    Code:
    DIG NS domain.tk

    and syslog (named)

    Code:
    Sep 16 10:56:03 server1 named[2820]: received control channel command 'reload'
    Sep 16 10:56:03 server1 named[2820]: loading configuration from '/etc/bind/named.conf'
    Sep 16 10:56:03 server1 named[2820]: reading built-in trusted keys from file '/etc/bind/bind.keys'
    Sep 16 10:56:03 server1 named[2820]: using default UDP/IPv4 port range: [1024, 65535]
    Sep 16 10:56:03 server1 named[2820]: using default UDP/IPv6 port range: [1024, 65535]
    Sep 16 10:56:03 server1 named[2820]: sizing zone task pool based on 166 zones
    Sep 16 10:56:03 server1 named[2820]: using built-in root key for view _default
    Sep 16 10:56:03 server1 named[2820]: Warning: 'empty-zones-enable/disable-empty-zone' not set: disabling RFC 1918 empty zones
    Sep 16 10:56:03 server1 named[2820]: reloading configuration succeeded
    Sep 16 10:56:03 server1 named[2820]: reloading zones succeeded
    Sep 16 10:56:03 server1 named[2820]: zone domain.org/IN: loaded serial 2013091605
    Sep 16 10:56:03 server1 named[2820]: zone domain.org/IN: sending notifies (serial 2013091605)
    btw… there is nothing about the tk domain…
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The dig command iyou used queries external servers and not your local server. Use:

    dig @localhost NS domain.tk
     
  5. stef157

    stef157 Member

    So i've this kind of message :

    Code:
    [email protected]:~# dig @localhost NS domain.tk
    
    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> @localhost NS domain.tk
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10076
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;domain.tk.			IN	NS
    
    ;; ANSWER SECTION:
    domain.tk.		86400	IN	NS	sdns2.ovh.net.
    domain.tk.		86400	IN	NS	server1.domain.org.
    
    ;; ADDITIONAL SECTION:
    server1.domain.org.	86400	IN	A	IPV4
    server1.domain.org.	86400	IN	AAAA	IPV6
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Sep 16 11:25:55 2013
    ;; MSG SIZE  rcvd: 139
    Sorry if it's not the real domain but it's not in prod and so nothing is secure yet :-|
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The message shows that the zone is working correctly.
     
  7. stef157

    stef157 Member

    Yes… But when I check on my computer, there is no answer for the domain and on whatsmydns.net, there is only 2 server who show the information…

    And some time on of those show a red cross…
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely they dont query your server yet or the dns changes have not been propagated yet or there is a config isue in the dns server / whois of the domain registrar.
     
  9. stef157

    stef157 Member

    Ok, so for you,
    I've to wait some time then try again ?

    Cause, we have other domain .tk who work fine (but registered some time ago…)

    btw… thanks for your help !
    and if it's just a propagation issue, sorry for this thread :-|

    Update :
    It apear that the port 53 os closed..
    How can I fixe that ?
    Thanks


    Update 2 :
    To resolve the problem :
    vi /etc/bind/named.conf.options

    Code:
    listen-on-v6 { any; };
    listen-on { 127.0.0.1; IP_SERVER; };
    And now all seem to be fine
     
    Last edited: Sep 17, 2013

Share This Page