Server name change stops webmail working

Discussion in 'Installation/Configuration' started by shajazzi, May 15, 2006.

  1. shajazzi

    shajazzi New Member

    Cannot log in to UebiMiau webmail after server name change.
    I took the following steps.


    echo mail.webnet4u.co.uk > /etc/hostname
    /bin/hostname -F /etc/hostname

    postconf -e 'mydomain = webnet4u.co.uk'
    postconf -e 'myhostname = mail.$mydomain'

    changed the hostname of your server in ISPConfig under management > server > settings and in /etc/hostname too.

    In /etc/ I noticed 2 hostnames

    /etc/hostname was already changed
    /etc/HOSTNAME/ I had to change manually

    then I restarted Postfix and now i cannot login to webmail
    I`ve tried reinstalling postfix and webmail and still no go.

    In the mail log i have the following:

    May 15 21:29:52 mail pop3d: Connection, ip=[::ffff:127.0.0.1]
    May 15 21:29:57 mail pop3d: LOGIN FAILED, ip=[::ffff:127.0.0.1]
    May 15 21:30:27 mail postfix/master[7013]: terminating on signal 15
    May 15 21:30:28 mail postfix/postfix-script: starting the Postfix mail system
    May 15 21:30:28 mail postfix/master[7913]: daemon started -- version 2.2.1, configuration /etc/postfix
    May 15 21:30:28 mail postfix/qmgr[7922]: 0B3E049AEA: from=<steve@englandshirt.com>, size=723, nrcpt=1 (queue active)
    May 15 21:30:28 mail postfix/smtp[7930]: warning: connect to private/tlsmgr: No such file or directory
    May 15 21:30:28 mail postfix/qmgr[7922]: 0776F49B9A: from=<dave@chace-catering.co.uk>, size=1116, nrcpt=1 (queue active)
    May 15 21:30:28 mail postfix/qmgr[7922]: 7A67349AEE: from=<steve@englandshirt.com>, size=723, nrcpt=1 (queue active)
    May 15 21:30:28 mail postfix/qmgr[7922]: CFC5549AFC: from=<dave@www.chace-catering.co.uk>, size=463, nrcpt=1 (queue active)
    May 15 21:30:28 mail postfix/qmgr[7922]: C2BD049457: from=<steve@englandshirt.com>, size=874, nrcpt=1 (queue active)
    May 15 21:30:28 mail postfix/qmgr[7922]: C6EED49BF8: from=<steve@englandshirt.com>, size=721, nrcpt=1 (queue active)
    May 15 21:30:29 mail postfix/smtp[7930]: warning: connect to private/tlsmgr: No such file or directory
    May 15 21:30:29 mail postfix/smtp[7930]: warning: problem talking to server private/tlsmgr: No such file or directory
    May 15 21:30:29 mail postfix/smtp[7930]: warning: no entropy for TLS key generation: disabling TLS support
    May 15 21:30:29 mail postfix/smtp[7932]: warning: connect to private/tlsmgr: No such file or directory
    May 15 21:30:30 mail postfix/smtp[7930]: connect to mailin-04.mx.aol.com[205.188.156.249]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    May 15 21:30:30 mail postfix/smtp[7932]: warning: connect to private/tlsmgr: No such file or directory
    May 15 21:30:30 mail postfix/smtp[7932]: warning: problem talking to server private/tlsmgr: No such file or directory
    May 15 21:30:30 mail postfix/smtp[7932]: warning: no entropy for TLS key generation: disabling TLS support
    May 15 21:30:30 mail postfix/smtp[7934]: warning: connect to private/tlsmgr: No such file or directory
    May 15 21:30:30 mail postfix/smtp[7930]: connect to mailin-04.mx.aol.com[64.12.138.152]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)



    It appears that my box is trying to contact AOL
    How do i stop this?


    Any ideas?
    please


    shajazzi
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The webmail login is trough pop3 (courier, ipop3d or something like that) but not through postfix.

    Can you fetch email with e.g. thunderbird or outlook?

    Please post the output of:

    netstat -tap
     
  3. shajazzi

    shajazzi New Member

    No I cannot recieve mail through outlook
    Here are the results of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 6587/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 6229/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 5379/ispconfig_http
    tcp 0 0 192.168.1.182:domain *:* LISTEN 6600/named
    tcp 0 0 *:ftp *:* LISTEN 7282/proftpd: (acce
    tcp 0 0 www.3lions2006.c:domain *:* LISTEN 6600/named
    tcp 0 0 192.168.1.104:domain *:* LISTEN 6600/named
    tcp 0 0 192.168.1.101:domain *:* LISTEN 6600/named
    tcp 0 0 192.168.1.181:domain *:* LISTEN 6600/named
    tcp 0 0 localhost:domain *:* LISTEN 6600/named
    tcp 0 0 *:ipp *:* LISTEN 6750/cupsd
    tcp 0 0 *:smtp *:* LISTEN 7140/master
    tcp 0 0 localhost:953 *:* LISTEN 6600/named
    tcp 0 0 localhost:37435 *:* LISTEN 7220/kded [kdeinit]
    tcp 0 0 192.168.1.181:39297 64.233.183.147:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:46852 www.novell.com:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:34502 omniture.112.2:www-http TIME_WAIT -
    tcp 0 0 192.168.1.181:50585 64.233.183.99:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:52003 195.12.230.206:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:50353 195.12.230.198:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:39288 a195-113-150-2:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:37033 a195-113-150-2:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 192.168.1.181:39893 66.249.93.104:www-http ESTABLISHED 10510/firefox-bin
    tcp 0 0 *:imaps *:* LISTEN 6410/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 6434/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 6412/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 6364/couriertcpd
    tcp 0 0 *:www-http *:* LISTEN 7216/httpd2-prefork
    tcp 0 0 *:ssh *:* LISTEN 7283/sshd
    tcp 0 0 *:smtp *:* LISTEN 7140/master
    tcp 0 0 localhost:953 *:* LISTEN 6600/named
    tcp 0 0 *:https *:* LISTEN 7216/httpd2-prefork

    The ip of my server is 192.168.1.110
    I can see no reference to this in netstat -tap, but the sites are all running fine.

    shajazzi
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message?
    Your POP3 server is running (Courier). Make sure your firewall doesn't block port 110.
     

Share This Page