Server name and IP address blank

Discussion in 'Installation/Configuration' started by PacketPaul, Oct 3, 2007.

  1. PacketPaul

    PacketPaul New Member

    I have installed ISPConfig under CentOS 5.0. My problem is the server name and IP address is blank when trying to setup a new site.

    To try and fix the problem, I go under Management -> Server -> Settings and enter a new hostname, and ip addresses. Yet when I try and save the configuration, the page simply returns with the default settings.

    Ideas, suggestions?

    Take care,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install the ISPConfig maysql dump manually?
  3. PacketPaul

    PacketPaul New Member

    No ... but here is the complete story.

    When I was installing ISPConfig I created a mysql user called "ISPConfig" and then created a database for which the user ISPConfig has full privileges. The installation completed but ISPConfig did not work at all. I looked at the ISPConfig database and found it totally blank.

    So it occurred to me it might be a bug in the installation script which prevented the installation from working on a database that was already created. So, under mysql I deleted the DB and re-ran the installation script. That had better results but things were still far from perfect.

    First, I found that httpd would not start. After reading a few posts on this board I found out SELinux was still enabled (which was quite strange as I had disabled it using the Setup Utility under CentOS). I manually disabled SELinux and rebooted the machine. Now httpd works.

    I am thinkng it might be best to uninstall and resinstall ISPConfig. When I run the script uninstall under /root/ispconfig I receive the following message:

    No results found!

    Thanks for your help!

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig must be able to create the mysql database again, if a database exists, the installation will fail. Have a look at the installation manual for the ISPConfig installation instructions and at the perfect setup guide for the linux setup. The User that you use for ISPConfig must have mysql root user priveliges.

    You will have to uninstall ISPConfig by executing:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    and delete the database that you created for ISPConfig.

    Thenn unpack the ISPCongig installer tar.gz again and run the setup script.
  5. PacketPaul

    PacketPaul New Member

    I deleted the directories and DB as suggested. I reinstalled ISPConfig as suggested and now receive the following log messages when I try to create a site:

    03.10.2007 - 16:00:33 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 514: Connected successfully
    03.10.2007 - 16:00:33 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 516: Could not select database

  6. PacketPaul

    PacketPaul New Member

    Ok, I just read the configuration file:

    or die($mod->log->ext_log("Could not select database", 2, $this->FILE,__LINE__));

    Does the ISPConfig DB user need "root" access to the mysql database? The DB user I created for ISPConfig does not have privileges under the mysql db.

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    From my answer above:

    The User that you use for ISPConfig must have mysql root user priveliges.
  8. PacketPaul

    PacketPaul New Member

    Ok that fixed it.



Share This Page