Server managers familiar with ISPConfig

Discussion in 'General' started by ashleykaryl, Dec 27, 2010.

  1. ashleykaryl

    ashleykaryl New Member

    A few minutes ago I tried adding a new domain to my server running ISPConfig 3 and moments later I lost all access to the control panel, while no domain hosted on the server can be accessed via the internet either. It could be a complete coincidence and related to my server host, who I have emailed, but it seems unlikely. Curiously I can still ping my domains and use email plus FTP is still working.

    I tried to get in touch with my server manager who was the last person to do any work on the server and found a message on his website saying that he was shutting shop, so I emailed him but it's around 5.00am where he is now and I have no idea when he will answer.

    Does anybody know of a reasonably competent server manager who is familiar with ISPConfig that I could contact for help occasionally? Most of the time I just leave it alone but I'd like to get this sorted fairly quickly and find somebody who can do the odd bit of maintenance work when required. Perhaps somebody can send me a PM if they can help in some way.

    Thanks

    Ashley
     
  2. ashleykaryl

    ashleykaryl New Member

    I've just done a server reboot through the control panel at Hetzner but nothing has changed.
     
  3. Toucan

    Toucan New Member

    About half an hour ago, your sites in your signature did indeed appear to be off line. However, since then I tried your http://ip and it brought up the apache test page. Tried the sites again and they appear to be working.
     
  4. ashleykaryl

    ashleykaryl New Member

    Thanks Toucan, the problem is fixed now after I managed to contact the old server manager. He found there was some issue with fast-cgi that occurred when I tried adding a new domain and it pretty much messed up everything as you saw. He was able to force it back onto SuPhp and then it all returned to normal.

    One way or another fast-cgi has been the source of ongoing problems on my server with ISPConfig and I just don't know why it has been so tricky. This is the second server manager who has battled with fast-cgi and we've done clean installs a couple of times. In the short term I'll avoid adding any more domains in case it breaks again. It's all very strange.
     
  5. Toucan

    Toucan New Member

    I know there have previously been some issues running suphp and fastcgi on the same web server, particularly with older versions of apache.

    Although, saying that, both seem to run fine on my servers
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I install ispconfig servers regularily for our customers and never had a problem related to fastcgi while all sites on these seervers use fastcgi. Which guide did you use to install your server and which ispconfig version do you use?

    The only thing that I can think of is that your server managers are not familar with ispconfig and though try to do modifications on the fastcgi scripts that are incompatible with ispconfig ot that they did not follow the perfects etup guide to install the systems.
     
  7. ashleykaryl

    ashleykaryl New Member

    I know that the first server manager had never installed ISPConfig before but he was very experienced with servers in general and ran the IT department for a university. He originally set up everything with mod-php from memory and it all worked well, except that it proved impossible to update Wordpress or any of the associated plugins. Any attempt to change from mod-php was taking my sites off line. This left me with a bit of a mess to clean up and he was inclined to disappear for long periods so I decided to cut my losses and find somebody else.

    The new server manager is more familiar with cPanel and Virtualmin but has previously installed ISPConfig on various servers. He battled for a while with the old set up but concluded we would be better off with a clean install, so he followed the perfect server setup guide for ISPConfig with Centos, however we still had problems with fast-cgi.

    Eventually (after several days) he got it to work with fast-cgi on my one domain running the wordpress blog by using some kind of workaround and all the other domains are on su-php. That problem yesterday occurred because I had attempted to add a new domain and fast-cgi was selected rather than su-php. In the past it has only affected the selected domain and I had hoped it would be OK this time but instead it broke all of them. I am running ISPConfig 3.0.3.

    I perfectly understand that it shouldn't be like this but it's been a problem since day one and now my server manager has effectively closed his business. He has told me he will still be available for occasional work but realistically it won't be that easy if he gets another job and it was hard enough already with the time difference because he is in Australia and I am in the UK.

    In many ways I prefer ISPConfig to WHM/cPanel that I was using on my last server and I would feel the same way even if cPanel was free. This fast-cgi headache though has taken up an awful lot of time and it always feels rather delicate, so in the long term I either need to find somebody who is really good with ISPConfig or reluctantly change to an alternative.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then this workaround might causing you problems. We run several wordpress sites on ispconfig 3 with fcgi, its a normal install without any workarounds needed.

    If you need ispconfig support, you can find our address under support on ispconfig.org.
     

Share This Page