Server "it works" page :(

Discussion in 'Installation/Configuration' started by Brando753, Jul 30, 2010.

  1. Brando753

    Brando753 New Member

    Alright I set up my server and installed ispConfig. However when I go to my domain it shows me the apache "it Works" page rather then the proper index.html

    site is please help.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Add the Ip for your website under System > server IP and thens elect this IP in the website settings.
  3. Brando753

    Brando753 New Member

    no go :(

    unfortunately I have already done that :(

    any other ideas?

    if you want to try use the username/password: howto
    Last edited: Jul 30, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Apache delivers the it works page if there is no matching domain / IP combination:

    1) Ensure that you enabled auto subdomain www.
    2) That you entered and not into the domain field of the website.
    3) Thats you have dns a-records for and that match the IP address that you selected in the website settings.
    4) If you run the server behind a router, the website IP must be the internal and not external Ip while you have to use the external IP in the DNS records.
    5) That the jobqueue is empty in the monitor.
    6) That you do not have any errors in the system log.
    7) That you followed exactly the perfect server guide for ISPConfig 3 to install your system.
  5. Brando753

    Brando753 New Member

    Alright thanks a bunch its working Now :D
  6. Brando753

    Brando753 New Member

    well i thought it was working as I can access the page when i type in however no one else can access the page outside the LAN. what did I do wrong?

  7. falko

    falko Super Moderator ISPConfig Developer

    Does your router forward port 80 to your ISPConfig server?
    Also, make sure that your ISP doesn't block port 80.
  8. Brando753

    Brando753 New Member

    I figured it out :D port 80 was blocked by ISP so i changed it to port 8000
  9. kwickcut

    kwickcut Member

  10. Brando753

    Brando753 New Member

    Port 8080 shows ISPConfig
    Port 8000 shows Website

Share This Page